summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <michal.privoznik@gmail.com>2023-08-28 10:31:29 +0200
committerSam James <sam@gentoo.org>2023-09-06 10:05:44 +0100
commit0e33bcc6940a140cc273a66c41bd69d8ee4f5ba2 (patch)
treef37540b50fd9b552af590e48b421143f05e3bda6 /app-emulation
parentapp-emulation/virtiofsd: Add 1.8.0 (diff)
downloadgentoo-0e33bcc6940a140cc273a66c41bd69d8ee4f5ba2.tar.gz
gentoo-0e33bcc6940a140cc273a66c41bd69d8ee4f5ba2.tar.bz2
gentoo-0e33bcc6940a140cc273a66c41bd69d8ee4f5ba2.zip
app-emulation/qemu: Adapt live ebuild to meson subprojects
The upstream is moving away from explicit git submodules to meson subprojects. This renders EGIT_SUBMODULES useless (wrt submodules we care about), but as there are still some submodules (that we don't care about) set the variable to empty array. Unfortunately, our meson.eclass doesn't support subpojects yet, therefore mimic what at least one other ebuild does (sys-apps/dbus-broker): provide an alternative implementation of src_unpack() for the live ebuild that downloads additional repositories via 'meson subprojects download'. The non-live ebuilds do not need this because the release archive contains bundles all subprojects. Signed-off-by: Michal Privoznik <michal.privoznik@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32484 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index cca0a24a89c0..6ca0885e7e59 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -25,11 +25,7 @@ if [[ ${PV} == *9999* ]]; then
QEMU_DOCS_PREBUILT=0
EGIT_REPO_URI="https://gitlab.com/qemu-project/qemu.git/"
- EGIT_SUBMODULES=(
- tests/fp/berkeley-softfloat-3
- tests/fp/berkeley-testfloat-3
- subprojects/keycodemapdb
- )
+ EGIT_SUBMODULES=()
inherit git-r3
SRC_URI=""
else
@@ -440,6 +436,14 @@ check_targets() {
popd >/dev/null
}
+if [[ ${PV} == 9999 ]]; then
+src_unpack() {
+ git-r3_src_unpack
+ cd "${P}" || die
+ meson subprojects download keycodemapdb berkeley-softfloat-3 berkeley-testfloat-3 || die
+}
+fi
+
src_prepare() {
check_targets IUSE_SOFTMMU_TARGETS softmmu
check_targets IUSE_USER_TARGETS linux-user
@@ -454,7 +458,7 @@ src_prepare() {
MAKEOPTS+=" V=1"
# Remove bundled modules
- rm -r subprojects/dtc roms/*/ || die
+ rm -r roms/*/ || die
}
##