summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2024-01-10 18:53:53 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2024-01-10 18:53:53 -0600
commit69d9565fdcadf74bca9f024ec3480662644b11ed (patch)
tree58ffcb24b18755b845c11761b75b11dbe9773cd5 /app-emulation
parentnet-misc/memcached: add 1.6.23 (diff)
downloadgentoo-69d9565fdcadf74bca9f024ec3480662644b11ed.tar.gz
gentoo-69d9565fdcadf74bca9f024ec3480662644b11ed.tar.bz2
gentoo-69d9565fdcadf74bca9f024ec3480662644b11ed.zip
app-emulation/diskimage-builder: add 3.32.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-3.32.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index f6fa011cf86f..814859957173 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1 +1,2 @@
DIST diskimage-builder-3.31.0.tar.gz 528537 BLAKE2B 34029716e3ade55b79a46c4e93ffb3d69d5f272d5ca11be74a26d41472816e6d83f0aedbbff86bb3309456c74843debb96ecccfb79aa839ddf4bef8a1c9c3ee1 SHA512 37362a5b1c58ecf35dfdd16eb20a061f3433751f513df0c4567f0ff495e9750a8c0aa32329be3a8e652d29b082656674e7518e9ea3317b1dbf6a80a46a70cdef
+DIST diskimage-builder-3.32.0.tar.gz 532942 BLAKE2B e436e5268b649dc5e050f66b098e527b79f172df00da93f23c115e3d88692c3f6546774c2046c8d4722cdd4139af4d05701725496f283b60e08ce0885b70de66 SHA512 6f5c2e0df428bf85b847fdc0ceebfdb66823b92b5b903de247d0e83ff2588c36e6f9786ea91f252c838cedeec22913f491d79643e77d83ad1fb690da7566af47
diff --git a/app-emulation/diskimage-builder/diskimage-builder-3.32.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-3.32.0.ebuild
new file mode 100644
index 000000000000..85165184e667
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-3.32.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10,11} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder"
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ inherit pypi
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"