summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-11-01 17:08:38 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-11-01 17:10:52 +0100
commit90fa7c14195abca32a9986303661a90373aec776 (patch)
treeb1a90376ed630e888d7d464461175f2ddd95f2c2 /app-emulation
parentsys-auth/oath-toolkit: drop 2.6.9 (diff)
downloadgentoo-90fa7c14195abca32a9986303661a90373aec776.tar.gz
gentoo-90fa7c14195abca32a9986303661a90373aec776.tar.bz2
gentoo-90fa7c14195abca32a9986303661a90373aec776.zip
app-emulation/grub-xen-host: drop 1.0-r1
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/grub-xen-host/grub-xen-host-1.0-r1.ebuild98
1 files changed, 0 insertions, 98 deletions
diff --git a/app-emulation/grub-xen-host/grub-xen-host-1.0-r1.ebuild b/app-emulation/grub-xen-host/grub-xen-host-1.0-r1.ebuild
deleted file mode 100644
index 2aaa8eb6a896..000000000000
--- a/app-emulation/grub-xen-host/grub-xen-host-1.0-r1.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Grub2 built as a PV grub per the Xen PV Boot Protocol"
-HOMEPAGE="https://wiki.xenproject.org/wiki/PvGrub2"
-SRC_URI=""
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="pvh"
-
-DEPEND="sys-boot/grub:2=[grub_platforms_xen]
- pvh? ( >=sys-boot/grub-2.04:2=[grub_platforms_xen-pvh] )
- app-emulation/xen-tools:="
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}"
-
-RESTRICT="binchecks strip test"
-
-src_configure() {
- :
-}
-
-src_compile() {
- cat > "${S}/grub-bootstrap.cfg" <<- EOF || die
- normal (memdisk)/grub.cfg
- EOF
-
- cat > "${S}/grub.cfg" <<- EOF || die
- if search -s -f /boot/xen/pvboot-x86_64.elf ; then
- echo "Chainloading (${root})/boot/xen/pvboot-x86_64.elf"
- multiboot "/boot/xen/pvboot-x86_64.elf"
- boot
- fi
-
- if search -s -f /xen/pvboot-x86_64.elf ; then
- echo "Chainloading (${root})/xen/pvboot-x86_64.elf"
- multiboot "/xen/pvboot-x86_64.elf"
- boot
- fi
-
- if search -s -f /boot/grub/grub.cfg ; then
- echo "Reading (${root})/boot/grub/grub.cfg"
- configfile /boot/grub/grub.cfg
- fi
-
- if search -s -f /grub/grub.cfg ; then
- echo "Reading (${root})/grub/grub.cfg"
- configfile /grub/grub.cfg
- fi
- EOF
-
- tar cf memdisk.tar grub.cfg || die "failed to tar"
-
- local grub_mkimage=grub-mkimage
- if type grub2-mkimage &> /dev/null; then
- grub_mkimage=grub2-mkimage
- fi
-
- local args=(
- "${grub_mkimage}"
- -O x86_64-xen
- -c grub-bootstrap.cfg
- -m memdisk.tar
- -o grub-x86_64-xen.bin
- /usr/lib/grub/x86_64-xen/*.mod
- )
-
- echo "${args[@]}"
- "${args[@]}" || die "failed to grub-mkimage"
-
- if use pvh; then
- local args=(
- "${grub_mkimage}"
- -O i386-xen_pvh
- -c grub-bootstrap.cfg
- -m memdisk.tar
- -o grub-i386-xen_pvh.bin
- /usr/lib/grub/i386-xen_pvh/*.mod
- )
-
- echo "${args[@]}"
- "${args[@]}" || die "failed to grub-mkimage"
- fi
-
-}
-
-src_install() {
- exeinto /usr/libexec/xen/bin
- doexe grub-x86_64-xen.bin
- if use pvh; then
- doexe grub-i386-xen_pvh.bin
- fi
-}