summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMo Zhou <cdluminate@gmail.com>2019-06-25 09:05:15 +0000
committerBenda Xu <heroxbd@gentoo.org>2019-06-25 18:57:59 +0800
commit111f0de1c6a774430837161b1bca64747bb0b58c (patch)
treea58c254620db36d59eb1096485066228394319de /app-eselect/eselect-lapack/eselect-lapack-0.2.ebuild
parentwww-client/opera-beta: Old (diff)
downloadgentoo-111f0de1c6a774430837161b1bca64747bb0b58c.tar.gz
gentoo-111f0de1c6a774430837161b1bca64747bb0b58c.tar.bz2
gentoo-111f0de1c6a774430837161b1bca64747bb0b58c.zip
app-eselect/eselect-{blas,lapack}: new design for BLAS/LAPACK switch.
As discussed in the gentoo-dev, it is decided to adopt the runtime switching of BLAS/CBLAS that has been proved by the experience of Debian. The Gentoo libgcc-style ld.so.conf runtime switching has been adopted as well, so as to avoid changing symlinks in /usr ignoring package manager. This design solves all the remaining problems regarding BLAS/LAPACK, thus making alternative-2.eclass (runtime switching of build options) and proposed USE_EXPAND (PYTHON_TARGET like eclass) obsolete. Finally we are at it. Thanks to all for years of ideas, debates and hard work. Reference: https://archives.gentoo.org/gentoo-dev/message/0177fea10e3ee06d85713101d17fc8d6 Closes: https://bugs.gentoo.org/632624 Closes: https://bugs.gentoo.org/470908 Closes: https://bugs.gentoo.org/267691 Closes: https://github.com/gentoo/gentoo/pull/12316 Closes: https://github.com/gentoo/gentoo/pull/12318 Closes: https://github.com/gentoo/sci/pull/835 Closes: https://github.com/gentoo/sci/pull/837 Credit: Dominik Schmidt, TheChymera, kiwifb, lkraav, Alessandro-Barbieri Signed-off-by: Mo Zhou <cdluminate@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'app-eselect/eselect-lapack/eselect-lapack-0.2.ebuild')
-rw-r--r--app-eselect/eselect-lapack/eselect-lapack-0.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-eselect/eselect-lapack/eselect-lapack-0.2.ebuild b/app-eselect/eselect-lapack/eselect-lapack-0.2.ebuild
new file mode 100644
index 000000000000..5fcf3f21f415
--- /dev/null
+++ b/app-eselect/eselect-lapack/eselect-lapack-0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="LAPACK module for eselect"
+HOMEPAGE="https://www.gentoo.org"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+# Need skel.bash lib
+RDEPEND=( ">=app-admin/eselect-1.0.5" )
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+src_install() {
+ local MODULEDIR="/usr/share/eselect/modules"
+ local MODULE="lapack"
+ insinto ${MODULEDIR}
+ newins "${FILESDIR}"/${MODULE}.eselect-${PVR} ${MODULE}.eselect
+ doman "${FILESDIR}"/lapack.eselect.5
+}