summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/skk-jisyo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/skk-jisyo')
-rw-r--r--app-i18n/skk-jisyo/Manifest1
-rw-r--r--app-i18n/skk-jisyo/files/unannotation.awk75
-rw-r--r--app-i18n/skk-jisyo/metadata.xml5
-rw-r--r--app-i18n/skk-jisyo/skk-jisyo-201101.ebuild57
-rw-r--r--app-i18n/skk-jisyo/skk-jisyo-9999.ebuild67
5 files changed, 205 insertions, 0 deletions
diff --git a/app-i18n/skk-jisyo/Manifest b/app-i18n/skk-jisyo/Manifest
new file mode 100644
index 000000000000..90b1c1c65799
--- /dev/null
+++ b/app-i18n/skk-jisyo/Manifest
@@ -0,0 +1 @@
+DIST skk-jisyo-201101.tar.bz2 7880875 SHA256 a57d9a39b705d13f8c90caf9ce8cf3f729852020a6e5b43bcc9e1d7383b252b4 SHA512 bbdaa6916bda9b545b4afc665fd9c7023797a2f1d2568c019b8f06515eca24f707cdcee8d85f3b0ea2793df4836a233eb131e78572229676cca909591f3e3648 WHIRLPOOL 11b4d880fb41f5fb3c704cc18c664ef0f043f6d232f34be6ba1c3737c7d9ccb0aec2361234ceea933e4ec4dbacc344de58af5d975c74412b847044df4aff89d9
diff --git a/app-i18n/skk-jisyo/files/unannotation.awk b/app-i18n/skk-jisyo/files/unannotation.awk
new file mode 100644
index 000000000000..88d9eb254344
--- /dev/null
+++ b/app-i18n/skk-jisyo/files/unannotation.awk
@@ -0,0 +1,75 @@
+# unannotation.awk: filter to remove annotations in dictionaries.
+#
+# Copyright (C) 2001, 2002 SKK Development Team <skk@ring.gr.jp>
+#
+# Maintainer: SKK Development Team <skk@ring.gr.jp>
+# Version: $Id: unannotation.awk,v 1.3 2006/01/04 10:35:06 skk-cvs Exp $
+# Last Modified: $Date: 2006/01/04 10:35:06 $
+#
+# This file is part of Daredevil SKK.
+#
+# Daredevil SKK is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or
+# (at your option) any later version.
+#
+# Daredevil SKK is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Daredevil SKK, see the file COPYING. If not, write to
+# the Free Software Foundation Inc., 51 Franklin St, Fifth Floor,
+# Boston, MA 02110-1301, USA.
+
+BEGIN{
+ print ";; -*- text -*-";
+ ctime = myctime(0);
+ this = ARGV[1];
+ if (match(this, /\.annotated$/) != 0){
+ this = substr(this, 1, RSTART - 1);
+ } else
+ this = this ".unannotated";
+ printf(";; %s was generated automatically by unannotation.awk at %s\n",
+ this, ctime);
+ #getline modeindicator
+ #if (match(modeindicator, /;; -*- text -*-/) != 0){
+ # print modeindicator;
+ #}
+}
+#$0 !~ /"^;; -\*- text -\*-\n"/{
+{
+ if (match($0, /^;/) == 0) {
+ gsub(";[^/]*/", "/");
+ if (DEQUOTE && $0 ~ /\\073/) {
+ $0 = dequote($0);
+ }
+ }
+ print;
+}
+function myctime(ts, format) {
+ format = "%a %b %e %H:%M:%S %Y";
+ if (ts == 0)
+ ts = systime(); # use current time as default
+ return strftime(format, ts);
+}
+# convert '\073' to ';' and strip '(concat "...")'.
+# example: 'smile /(concat "^_^\073\073")/:-)/' to 'smile /^_^;;/:-)/'
+# @param s string to convert
+# @return converted string
+function dequote(s) {
+ ret = "";
+ n = split(s, a, "/");
+ for (i = 1; i < n; i++) {
+ if (a[i] ~ /^\(concat ".*\\073.*"\)$/) { # \073 = ';'
+ gsub(/\\073/, ";", a[i]);
+ if (a[i] !~ /\\/) { # no other quote
+ a[i] = gensub(/^\(concat "(.*)"\)$/, "\\1", "g", a[i]);
+ }
+ }
+ ret = ret a[i] "/";
+ }
+ return ret;
+}
+# end of unannotation.awk.
diff --git a/app-i18n/skk-jisyo/metadata.xml b/app-i18n/skk-jisyo/metadata.xml
new file mode 100644
index 000000000000..2d5852c16c60
--- /dev/null
+++ b/app-i18n/skk-jisyo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cjk</herd>
+</pkgmetadata>
diff --git a/app-i18n/skk-jisyo/skk-jisyo-201101.ebuild b/app-i18n/skk-jisyo/skk-jisyo-201101.ebuild
new file mode 100644
index 000000000000..1e140be400af
--- /dev/null
+++ b/app-i18n/skk-jisyo/skk-jisyo-201101.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+DESCRIPTION="Jisyo (dictionary) files for the SKK Japanese-input software"
+HOMEPAGE="http://openlab.ring.gr.jp/skk/dic.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2 public-domain freedist"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="cdb"
+
+COMMON_DEPEND="cdb? ( dev-db/cdb )"
+DEPEND="${COMMON_DEPEND}
+ sys-apps/gawk"
+RDEPEND="${COMMON_DEPEND}
+ !app-i18n/skk-jisyo-extra
+ !app-i18n/skk-jisyo-cdb"
+
+src_prepare() {
+ rm SKK-JISYO.wrong.annotated SKK-JISYO.china_taiwan.header
+ rm SKK-JISYO.noregist SKK-JISYO.not_wrong SKK-JISYO.hukugougo
+ rm SKK-JISYO.notes SKK-JISYO.requested SKK-JISYO.pubdic+
+}
+
+src_compile() {
+ # bug 184457
+ unset LANG LC_ALL LC_CTYPE
+
+ for f in SKK-JISYO.* zipcode/SKK-JISYO.* ; do
+ mv ${f} ${f}.annotated
+ gawk -f "${FILESDIR}"/unannotation.awk ${f}.annotated > $(basename ${f}) || die
+ if use cdb ; then
+ gawk '
+ /^[^;]/ {
+ s = substr($0, index($0, " ") + 1)
+ print "+" length($1) "," length(s) ":" $1 "->" s
+ }
+ END {
+ print ""
+ }
+ ' $(basename ${f}) | cdbmake $(basename ${f}).cdb "${T}"/$(basename ${f}) || die
+ fi
+ rm ${f}.annotated
+ done
+}
+
+src_install() {
+ # install dictionaries
+ insinto /usr/share/skk
+ doins SKK-JISYO.* || die
+
+ dodoc ChangeLog* READMEs/committers.txt edict_doc.txt || die
+}
diff --git a/app-i18n/skk-jisyo/skk-jisyo-9999.ebuild b/app-i18n/skk-jisyo/skk-jisyo-9999.ebuild
new file mode 100644
index 000000000000..43b6f4d8a2ab
--- /dev/null
+++ b/app-i18n/skk-jisyo/skk-jisyo-9999.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+ECVS_SERVER="openlab.jp:/circus/cvsroot"
+ECVS_USER="guest"
+ECVS_PASS="guest"
+ECVS_MODULE="skk/dic"
+inherit cvs
+
+DESCRIPTION="Jisyo (dictionary) files for the SKK Japanese-input software"
+HOMEPAGE="http://openlab.ring.gr.jp/skk/dic.html"
+#SRC_URI="mirror://gentoo/${P}.tar.bz2"
+SRC_URI=""
+
+LICENSE="GPL-2 public-domain freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="cdb"
+
+COMMON_DEPEND="cdb? ( dev-db/cdb )"
+DEPEND="${COMMON_DEPEND}
+ sys-apps/gawk"
+RDEPEND="${COMMON_DEPEND}
+ !app-i18n/skk-jisyo-extra
+ !app-i18n/skk-jisyo-cdb"
+
+S="${WORKDIR}/${ECVS_MODULE}"
+
+src_unpack() {
+ cvs_src_unpack
+
+ cd "${S}"
+ rm SKK-JISYO.wrong.annotated SKK-JISYO.china_taiwan.header
+ rm SKK-JISYO.noregist SKK-JISYO.not_wrong SKK-JISYO.hukugougo
+ rm SKK-JISYO.notes SKK-JISYO.requested SKK-JISYO.pubdic+
+}
+
+src_compile() {
+ # bug 184457
+ unset LANG LC_ALL LC_CTYPE
+
+ for f in SKK-JISYO.* zipcode/SKK-JISYO.* ; do
+ mv ${f} ${f}.annotated
+ gawk -f "${FILESDIR}"/unannotation.awk ${f}.annotated > $(basename ${f}) || die
+ if use cdb ; then
+ gawk '
+ /^[^;]/ {
+ s = substr($0, index($0, " ") + 1)
+ print "+" length($1) "," length(s) ":" $1 "->" s
+ }
+ END {
+ print ""
+ }
+ ' $(basename ${f}) | cdbmake $(basename ${f}).cdb "${T}"/$(basename ${f}) || die
+ fi
+ rm ${f}.annotated
+ done
+}
+
+src_install() {
+ # install dictionaries
+ insinto /usr/share/skk
+ doins SKK-JISYO.* || die
+
+ dodoc ChangeLog* READMEs/committers.txt edict_doc.txt
+}