summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2023-08-21 22:29:26 +0900
committerAkinori Hattori <hattya@gentoo.org>2023-08-21 22:32:03 +0900
commit4fc023fc6a1edcea2311c27e0cb545eb29682c8c (patch)
tree9b35ab6a10dc47c329118da225fde627303ad508 /app-i18n
parentnet-analyzer/netdata: add 1.42.1 (diff)
downloadgentoo-4fc023fc6a1edcea2311c27e0cb545eb29682c8c.tar.gz
gentoo-4fc023fc6a1edcea2311c27e0cb545eb29682c8c.tar.bz2
gentoo-4fc023fc6a1edcea2311c27e0cb545eb29682c8c.zip
app-i18n/ibus-table-others: fix build with dev-lang/python-exec[-native-symlinks]
Closes: https://bugs.gentoo.org/912415 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-table-others/ibus-table-others-1.3.15.ebuild9
-rw-r--r--app-i18n/ibus-table-others/ibus-table-others-1.3.17.ebuild9
2 files changed, 18 insertions, 0 deletions
diff --git a/app-i18n/ibus-table-others/ibus-table-others-1.3.15.ebuild b/app-i18n/ibus-table-others/ibus-table-others-1.3.15.ebuild
index 01282c650fbd..02c15aee3b1d 100644
--- a/app-i18n/ibus-table-others/ibus-table-others-1.3.15.ebuild
+++ b/app-i18n/ibus-table-others/ibus-table-others-1.3.15.ebuild
@@ -3,6 +3,8 @@
EAPI="8"
+inherit autotools
+
DESCRIPTION="Various tables for IBus-Table"
HOMEPAGE="https://github.com/moebiuscurve/ibus-table-others"
SRC_URI="https://github.com/moebiuscurve/${PN}/releases/download/${PV}/${P}.tar.gz"
@@ -19,3 +21,10 @@ RDEPEND="app-i18n/ibus-table
!app-i18n/ibus-table-tv"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ sed -i '/AM_PATH_PYTHON/d' configure.ac
+
+ default
+ eautoreconf
+}
diff --git a/app-i18n/ibus-table-others/ibus-table-others-1.3.17.ebuild b/app-i18n/ibus-table-others/ibus-table-others-1.3.17.ebuild
index 3b9d129a0b69..8f38bd24b0bd 100644
--- a/app-i18n/ibus-table-others/ibus-table-others-1.3.17.ebuild
+++ b/app-i18n/ibus-table-others/ibus-table-others-1.3.17.ebuild
@@ -3,6 +3,8 @@
EAPI="8"
+inherit autotools
+
DESCRIPTION="Various tables for IBus-Table"
HOMEPAGE="https://github.com/moebiuscurve/ibus-table-others"
SRC_URI="https://github.com/moebiuscurve/${PN}/releases/download/${PV}/${P}.tar.gz"
@@ -19,3 +21,10 @@ RDEPEND="app-i18n/ibus-table
!app-i18n/ibus-table-tv"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ sed -i '/AM_PATH_PYTHON/d' configure.ac
+
+ default
+ eautoreconf
+}