summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2023-08-17 23:12:55 +0900
committerAkinori Hattori <hattya@gentoo.org>2023-08-17 23:12:55 +0900
commitdcc5a46e2cf9bb11c6090d50d9442dc881995e0a (patch)
tree4193a021160cc7a897f2917d4355fd243ff13c35 /app-i18n
parentapp-i18n/ibus-table: drop old (diff)
downloadgentoo-dcc5a46e2cf9bb11c6090d50d9442dc881995e0a.tar.gz
gentoo-dcc5a46e2cf9bb11c6090d50d9442dc881995e0a.tar.bz2
gentoo-dcc5a46e2cf9bb11c6090d50d9442dc881995e0a.zip
app-i18n/ibus-table: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-table/Manifest1
-rw-r--r--app-i18n/ibus-table/ibus-table-1.17.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-i18n/ibus-table/Manifest b/app-i18n/ibus-table/Manifest
index fc6592e66212..0f7e03ba31de 100644
--- a/app-i18n/ibus-table/Manifest
+++ b/app-i18n/ibus-table/Manifest
@@ -1 +1,2 @@
DIST ibus-table-1.17.0.tar.gz 1545826 BLAKE2B 33890dffca38c76513f49a54419805aff1b13e79b069cdb655401a44eeb44201c4cc60a29e9b341bd25dc9431a6e15e0481dc7cbd3ad3f02ae07cfcc6f811c81 SHA512 2df316dfe34eca80d9d4f843a92f3452a939cd14bca3bfa6c021b0bc6b759676711fefba68b9bf10dfe48c2f82890452e9ae015986b520281998f4d08f2e763b
+DIST ibus-table-1.17.1.tar.gz 1546204 BLAKE2B e6aa8fb66af08f504c032f9950c52ffc4eefd1633dfdb49e7c7eb4e38f9c103be1e845927a61418a1c1e028dcdf50ad8bd6d64640697506c15d82f7021282e64 SHA512 67168bb301820fa006208a15c3dc0f72480f8dd7bcd4097f0ee837fa44a1d04d68760f3061d655ec8a19ccb60aee2d6fd54bb5dd13668c61edb38b6e46f1b9ff
diff --git a/app-i18n/ibus-table/ibus-table-1.17.1.ebuild b/app-i18n/ibus-table/ibus-table-1.17.1.ebuild
new file mode 100644
index 000000000000..fa1d06003138
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.17.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Tables engines for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/kaio/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ virtual/libiconv
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ python_fix_shebang .
+
+ default
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}