summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-31 14:20:08 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-31 14:20:08 +0200
commitfab5eef76374e27acdf1aca851f5b7f336000159 (patch)
tree1c044fe77c266ec288e9143c0c6f76d96ecfbb40 /app-misc/acdctl/files
parentapp-misc/rlwrap: drop 0.42-r1, 0.43 (diff)
downloadgentoo-fab5eef76374e27acdf1aca851f5b7f336000159.tar.gz
gentoo-fab5eef76374e27acdf1aca851f5b7f336000159.tar.bz2
gentoo-fab5eef76374e27acdf1aca851f5b7f336000159.zip
app-misc/acdctl: update EAPI 6 -> 8
Closes: https://bugs.gentoo.org/722400 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-misc/acdctl/files')
-rw-r--r--app-misc/acdctl/files/acdctl-1.1-makefile.patch13
-rw-r--r--app-misc/acdctl/files/acdctl-1.1-warnings.patch20
2 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/acdctl/files/acdctl-1.1-makefile.patch b/app-misc/acdctl/files/acdctl-1.1-makefile.patch
new file mode 100644
index 000000000000..ac63da0c5e1d
--- /dev/null
+++ b/app-misc/acdctl/files/acdctl-1.1-makefile.patch
@@ -0,0 +1,13 @@
+--- a/Makefile
++++ b/Makefile
+@@ -25,8 +25,8 @@
+ #****************************************************************************
+
+
+-CFLAGS=-Wall
+-LDFLAGS=-lusb
++CFLAGS += -Wall
++LDLIBS = -lusb
+
+ all:acdctl
+
diff --git a/app-misc/acdctl/files/acdctl-1.1-warnings.patch b/app-misc/acdctl/files/acdctl-1.1-warnings.patch
new file mode 100644
index 000000000000..e86d80918b4a
--- /dev/null
+++ b/app-misc/acdctl/files/acdctl-1.1-warnings.patch
@@ -0,0 +1,20 @@
+--- a/acdctl.c
++++ b/acdctl.c
+@@ -130,7 +130,7 @@
+ next->vendor, next->product, next->description, next->year);
+ next++;
+ }
+- printf("\n%d displays supported\n", displayCount);
++ printf("\n%ld displays supported\n", displayCount);
+ }
+
+ void help(const char* program_name) {
+@@ -277,7 +277,7 @@
+ }
+
+ void found_display(int index, struct usb_device *dev) {
+- int ret;
++ int ret = 0;
+ usb_dev_handle* display_device = usb_open(dev);
+
+ if(display_device) {