summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-26 11:59:16 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-26 12:04:55 -0500
commit6394191ba04bcb5dd9a704936ce659ab6d1bffbe (patch)
treed8970f4eef2a8ed19b2a7b42489fe314922aba66 /app-misc/actkbd
parentkde-frameworks/kapidox: Add KDE_AUTODEPS=false (diff)
downloadgentoo-6394191ba04bcb5dd9a704936ce659ab6d1bffbe.tar.gz
gentoo-6394191ba04bcb5dd9a704936ce659ab6d1bffbe.tar.bz2
gentoo-6394191ba04bcb5dd9a704936ce659ab6d1bffbe.zip
app-misc/actkbd: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'app-misc/actkbd')
-rw-r--r--app-misc/actkbd/actkbd-0.2.8-r2.ebuild49
-rw-r--r--app-misc/actkbd/files/actkbd.initd4
2 files changed, 51 insertions, 2 deletions
diff --git a/app-misc/actkbd/actkbd-0.2.8-r2.ebuild b/app-misc/actkbd/actkbd-0.2.8-r2.ebuild
new file mode 100644
index 000000000000..ec6c410127e2
--- /dev/null
+++ b/app-misc/actkbd/actkbd-0.2.8-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info eutils toolchain-funcs
+
+DESCRIPTION="A keyboard shortcut daemon"
+HOMEPAGE="http://users.softlab.ece.ntua.gr/~thkala/projects/actkbd/"
+SRC_URI="http://users.softlab.ece.ntua.gr/~thkala/projects/actkbd/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+CONFIG_CHECK="~INPUT_EVDEV"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.2.7-amd64.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin actkbd
+ dodoc AUTHORS ChangeLog FAQ README TODO
+ docinto samples
+ dodoc samples/actkbd.conf
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}
+
+pkg_postinst() {
+ elog
+ elog "System-wide configuration file is /etc/actkbd.conf."
+ elog "Use actkbd.conf from usr/share/doc/${PF}/samples as a template."
+ elog "You need to create the config and set right input device from"
+ elog "/dev/input/event* in /etc/conf.d/actkbd"
+ elog
+ elog "To obtain keycodes for pressed combinations/keys just run:"
+ elog " # actkbd -s -d /dev/input/event<MYDEVICENUMBER>"
+}
diff --git a/app-misc/actkbd/files/actkbd.initd b/app-misc/actkbd/files/actkbd.initd
index e0fc046a7ff6..b0a8b5771368 100644
--- a/app-misc/actkbd/files/actkbd.initd
+++ b/app-misc/actkbd/files/actkbd.initd
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$