summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-03-23 14:28:50 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-03-23 14:36:36 -0700
commitbc27d9652c6f04bedd79b34b27f0613b56004ac9 (patch)
tree340375442568ce138ab9894f72c7bed84c3f6746 /app-misc/binwalk
parentapp-misc/binwalk: sync live ebuild keywords (diff)
downloadgentoo-bc27d9652c6f04bedd79b34b27f0613b56004ac9.tar.gz
gentoo-bc27d9652c6f04bedd79b34b27f0613b56004ac9.tar.bz2
gentoo-bc27d9652c6f04bedd79b34b27f0613b56004ac9.zip
app-misc/binwalk: bump to 2.3.0, simplify tests
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-misc/binwalk')
-rw-r--r--app-misc/binwalk/Manifest1
-rw-r--r--app-misc/binwalk/binwalk-2.3.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-misc/binwalk/Manifest b/app-misc/binwalk/Manifest
index dc96e51cb0f9..bfb5af597267 100644
--- a/app-misc/binwalk/Manifest
+++ b/app-misc/binwalk/Manifest
@@ -1 +1,2 @@
DIST binwalk-2.2.0.tar.gz 39594514 BLAKE2B 899a919647258759f16c2e59766b0db68d1a78edf0f5c3755c2a987695199a1851deed2820e6323d82d8af85d294a6f1fcafb655e5d2257d49b673ddae49da67 SHA512 5f3ed31c0b5f9ca3057f86e82787a73b06f9f73747b51dd72130a78e4d69cf43a0207bffc495d177e97811de5bf835b3d0507f314b7a0c960eddf6d1efe0f0f9
+DIST binwalk-2.3.0.tar.gz 39603727 BLAKE2B abdb9909cf92a6cb35035c98467162dab2b009f5eab4bf255bba14ce82c2748cbd648977a54f276f2c141897b4e7a592d0adbde77a3c0f4164b04b7c328bc7e5 SHA512 74c25858eccaeff1bbf238cdff92df4cbec37dfff77204739bd82c35e4fd2329a8d0b13850b8b05900f756a99b898ebbbfb8ac44a26f37ca3ffb16c72402f9d6
diff --git a/app-misc/binwalk/binwalk-2.3.0.ebuild b/app-misc/binwalk/binwalk-2.3.0.ebuild
new file mode 100644
index 000000000000..d819647e95dc
--- /dev/null
+++ b/app-misc/binwalk/binwalk-2.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/ReFirmLabs/binwalk.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ReFirmLabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="A tool for identifying files embedded inside firmware images"
+HOMEPAGE="https://github.com/ReFirmLabs/binwalk"
+
+LICENSE="MIT"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.2.0-disable-test-coverage.patch )
+
+distutils_enable_tests --install nose
+
+python_install_all() {
+ local DOCS=( API.md INSTALL.md README.md )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "binwalk has many optional dependencies to automatically"
+ elog "extract/decompress data, see INSTALL.md for more details."
+ fi
+}