summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2019-10-20 21:13:05 +0200
committerSebastian Pipping <sping@gentoo.org>2019-10-20 21:13:05 +0200
commit0b09b635900d9fdd27fc3311ead29353f546a7bb (patch)
tree1fad1523f41415077e5777cfa153cc292779ff53 /app-misc/resolve-march-native/resolve-march-native-0.9.3.ebuild
parentsys-cluster/slurm: remove EnvironmentFile from systemd units (diff)
downloadgentoo-0b09b635900d9fdd27fc3311ead29353f546a7bb.tar.gz
gentoo-0b09b635900d9fdd27fc3311ead29353f546a7bb.tar.bz2
gentoo-0b09b635900d9fdd27fc3311ead29353f546a7bb.zip
app-misc/resolve-march-native: 0.9.3 + Python 3
Closes: https://bugs.gentoo.org/695454 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.68, Repoman-2.3.16
Diffstat (limited to 'app-misc/resolve-march-native/resolve-march-native-0.9.3.ebuild')
-rw-r--r--app-misc/resolve-march-native/resolve-march-native-0.9.3.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/app-misc/resolve-march-native/resolve-march-native-0.9.3.ebuild b/app-misc/resolve-march-native/resolve-march-native-0.9.3.ebuild
new file mode 100644
index 000000000000..c2761b473b9d
--- /dev/null
+++ b/app-misc/resolve-march-native/resolve-march-native-0.9.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+inherit distutils-r1
+
+DESCRIPTION="Resolve GCC flag -march=native"
+HOMEPAGE="https://github.com/hartwork/resolve-march-native"
+SRC_URI="https://github.com/hartwork/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=sys-devel/gcc-4.2"