summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-02 20:32:56 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-02 20:33:16 -0800
commit5848db92e12dd63316ed19c40b3316b51f58c13b (patch)
treee91a744ed50613cdf8096cace28158ad053bb170 /app-misc/tmuxp/tmuxp-1.5.4.ebuild
parentnet-libs/rabbitmq-c: arm64 stable (bug #701810) (diff)
downloadgentoo-5848db92e12dd63316ed19c40b3316b51f58c13b.tar.gz
gentoo-5848db92e12dd63316ed19c40b3316b51f58c13b.tar.bz2
gentoo-5848db92e12dd63316ed19c40b3316b51f58c13b.zip
app-misc/tmuxp-1.5.4: Version bump, add py38, pypy{,3}
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc/tmuxp/tmuxp-1.5.4.ebuild')
-rw-r--r--app-misc/tmuxp/tmuxp-1.5.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-misc/tmuxp/tmuxp-1.5.4.ebuild b/app-misc/tmuxp/tmuxp-1.5.4.ebuild
new file mode 100644
index 000000000000..b801bfdbf430
--- /dev/null
+++ b/app-misc/tmuxp/tmuxp-1.5.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="tmux session manager. built on libtmux"
+HOMEPAGE="https://tmuxp.git-pull.com"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/kaptan[${PYTHON_USEDEP}]
+ >=dev-python/libtmux-0.8[${PYTHON_USEDEP}]
+ <dev-python/libtmux-0.9[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ <dev-python/click-8.0[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-4.1.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ SHELL="/bin/bash" pytest -vv || die "Tests fail with ${EPYTHON}"
+}