summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2024-08-01 13:40:03 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-08-10 10:20:10 +0300
commit3d5c9a9f958b31dde08a8e481d145463f808ae60 (patch)
tree7d8b54667f021802f6802d9316d31e4f27593894 /app-misc
parentapp-dicts/myspell-en: add 20240801 (diff)
downloadgentoo-3d5c9a9f958b31dde08a8e481d145463f808ae60.tar.gz
gentoo-3d5c9a9f958b31dde08a8e481d145463f808ae60.tar.bz2
gentoo-3d5c9a9f958b31dde08a8e481d145463f808ae60.zip
app-misc/binwalk: add 2.4.2
Signed-off-by: David Roman <davidroman96@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/binwalk/Manifest1
-rw-r--r--app-misc/binwalk/binwalk-2.4.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/binwalk/Manifest b/app-misc/binwalk/Manifest
index fdd9fbae0916..279abd5f671d 100644
--- a/app-misc/binwalk/Manifest
+++ b/app-misc/binwalk/Manifest
@@ -1,2 +1,3 @@
DIST binwalk-2.4.0.tar.gz 39744574 BLAKE2B 8503e86afb584e431b25611fbed91e85aaf307e9011b5ef09a83b5f4756a815f9d3de67d440a2b7547cbe162d1940e8d6ffc4899afac14ccb938304002b1eb41 SHA512 41bee6a0d1cd587f81dcf81c30215a305b61e4db208bc9d8e4f0b9f12acb47e4dc2e6af23e06118ef6e30c484f6be743b456b6d4324be4388413ff291682345e
DIST binwalk-2.4.1.tar.gz 39747760 BLAKE2B 480f8ff06932c77ca5ab2857cddf7ecebb36b6f2e55e3ccf15a971fa0f4c59d57b652556fd9f0dd20e6fbd887fdef3c6da022f76787b2edf16b0d1714d291e8a SHA512 f83d0ca09a39033944ce16345b7c2c8f3051a20f80315e4c797221df4e6844c7c89c0a49053d739156e2654b482d6ef93f0814fa588daab031dbeaed1423e6f2
+DIST binwalk-2.4.2.tar.gz 39746629 BLAKE2B 65e3c44b2e2c4cc639ad6b8adf3fbac7cda574ca8b00f714d4ae5635dd3e24fcfc8c0d151c20ad40ad891adef803667e6f65167f96d4405ad83abee44121c224 SHA512 b9d3b13de9b81216759f5e1573bf6056a3210892ad920b43afe0c6ef2ff1d200be28ecfe12bec11fd7540545d1bb2f27d210ee5afb968910d4e9fb46a21673ce
diff --git a/app-misc/binwalk/binwalk-2.4.2.ebuild b/app-misc/binwalk/binwalk-2.4.2.ebuild
new file mode 100644
index 000000000000..b0874ff39ee8
--- /dev/null
+++ b/app-misc/binwalk/binwalk-2.4.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 optfeature
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/OSPG/binwalk.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/OSPG/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="A tool for identifying files embedded inside firmware images"
+HOMEPAGE="https://github.com/OSPG/binwalk"
+
+LICENSE="MIT"
+SLOT="0"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ local DOCS=( API.md INSTALL.md README.md )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "entropy graph" dev-python/matplotlib
+ optfeature "disassembly" dev-libs/capstone[python]
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "binwalk has many more optional dependencies to automatically"
+ elog "extract/decompress data, see INSTALL.md for more details."
+ fi
+}