summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-11-29 12:40:36 -0500
committerMatt Turner <mattst88@gentoo.org>2023-11-29 12:41:14 -0500
commit4d0f6ea3c6a5f6216ea75a4c6c7e960f7f2b08f3 (patch)
tree51df366e401cbe9c3c0a47a4a5a170833ced21af /app-misc
parentdev-python/rapidfuzz: Stabilize 3.5.2 sparc, #918813 (diff)
downloadgentoo-4d0f6ea3c6a5f6216ea75a4c6c7e960f7f2b08f3.tar.gz
gentoo-4d0f6ea3c6a5f6216ea75a4c6c7e960f7f2b08f3.tar.bz2
gentoo-4d0f6ea3c6a5f6216ea75a4c6c7e960f7f2b08f3.zip
app-misc/mosquitto: Drop old versions
Bug: https://bugs.gentoo.org/918540 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/mosquitto/Manifest2
-rw-r--r--app-misc/mosquitto/mosquitto-2.0.15-r1.ebuild127
-rw-r--r--app-misc/mosquitto/mosquitto-2.0.17.ebuild127
3 files changed, 0 insertions, 256 deletions
diff --git a/app-misc/mosquitto/Manifest b/app-misc/mosquitto/Manifest
index d688c1a81622..b32d0c372120 100644
--- a/app-misc/mosquitto/Manifest
+++ b/app-misc/mosquitto/Manifest
@@ -1,3 +1 @@
-DIST mosquitto-2.0.15.tar.gz 792632 BLAKE2B a6e986998473c16efd4c5fc5fd743782e085b3e7e30bcdcb867f0ae87f85e608f5d50d0dcc5bbbcc2f25eb6a618ab2f287fdcba47660fa593fe1636d08eb183e SHA512 8a0c58222ea0b9304e7f096f6d13965478072baf1d1c9bc931b32a33f5ea8196c2dd54bde8d83fec7ed9cd413cb5fb115ce0a6701ca20664df52fdd7ca63ddaf
-DIST mosquitto-2.0.17.tar.gz 795960 BLAKE2B 50a351ee6d5b29adc2f234fad9a8a084d35be5d219e8d20283a256075dc69c03ec39543924600dc424408951e2af5a6ae4afada20bf82a4f54dbbed101daee9b SHA512 0882380461bf110abe10c5487334b0ae5ce8d890a2ad8f9b419278a0f04fc821918f50408c50c843bf09741eb62d5b9a1ab10df262d46cd70aafc3e063344a9a
DIST mosquitto-2.0.18.tar.gz 796351 BLAKE2B 6e1d8078ee2813870d79489f312857a12614dc8f1fa3c72269ab29555897ec61d7ba54fcb5e5383f8e852cdb6fffa1d7cb2003ce15da12b986989a6187a186a0 SHA512 63f7e2811964bab5856848e6918627c47afc6534ff60aad5ece3d2fa330b407c9df14027610826e343ee68ff7d8d5d93f2459713061251ded478c42766946767
diff --git a/app-misc/mosquitto/mosquitto-2.0.15-r1.ebuild b/app-misc/mosquitto/mosquitto-2.0.15-r1.ebuild
deleted file mode 100644
index ab041935459f..000000000000
--- a/app-misc/mosquitto/mosquitto-2.0.15-r1.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit python-any-r1 systemd toolchain-funcs
-
-DESCRIPTION="An Open Source MQTT v3 Broker"
-HOMEPAGE="https://mosquitto.org/ https://github.com/eclipse/mosquitto"
-SRC_URI="https://mosquitto.org/files/source/${P}.tar.gz"
-
-LICENSE="EPL-1.0"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 x86"
-IUSE="bridge examples +persistence +srv ssl systemd tcpd test websockets"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="test? ( bridge )"
-
-RDEPEND="
- acct-user/mosquitto
- acct-group/mosquitto
- dev-libs/cJSON:=
- srv? ( net-dns/c-ares:= )
- ssl? (
- dev-libs/openssl:0=
- )
- systemd? ( sys-apps/systemd )
- tcpd? ( sys-apps/tcp-wrappers )
- websockets? ( net-libs/libwebsockets[lejp] )
-"
-DEPEND="
- ${RDEPEND}
- test? ( dev-util/cunit )
-"
-BDEPEND="
- test? ( ${PYTHON_DEPS} )
-"
-
-pkg_setup() {
- use test && python_setup
-}
-
-_emake() {
- local LIBDIR=$(get_libdir)
- emake \
- CC="$(tc-getCC)" \
- CXX="$(tc-getCXX)" \
- CLIENT_LDFLAGS="${LDFLAGS}" \
- LIB_SUFFIX="${LIBDIR:3}" \
- WITH_BRIDGE="$(usex bridge)" \
- WITH_PERSISTENCE="$(usex persistence)" \
- WITH_SRV="$(usex srv)" \
- WITH_SYSTEMD="$(usex systemd)" \
- WITH_TLS="$(usex ssl)" \
- WITH_WEBSOCKETS="$(usex websockets)" \
- WITH_WRAP="$(usex tcpd)" \
- "$@"
-}
-
-src_prepare() {
- default
- if use persistence; then
- sed -i -e "/^#autosave_interval/s|^#||" \
- -e "s|^#persistence false$|persistence true|" \
- -e "/^#persistence_file/s|^#||" \
- -e "s|#persistence_location|persistence_location /var/lib/mosquitto/|" \
- mosquitto.conf || die
- fi
-
- # Remove failing tests
- sed -i \
- -e '/06-bridge-reconnect-local-out.py/d' \
- test/broker/Makefile || die
- sed -i \
- -e '/02-subscribe-qos1-async2.test/d' \
- test/lib/Makefile || die
-
- # Extend test timeout to prevent spurious failures
- sed -i -e 's/SUB_TIMEOUT=1/SUB_TIMEOUT=3/' \
- test/client/test.sh || die
-
- use test && python_fix_shebang test
-}
-
-src_compile() {
- _emake
-}
-
-src_test() {
- _emake test
-}
-
-src_install() {
- _emake DESTDIR="${D}" prefix=/usr install
- keepdir /var/lib/mosquitto
- fowners mosquitto:mosquitto /var/lib/mosquitto
- dodoc README.md CONTRIBUTING.md ChangeLog.txt
- doinitd "${FILESDIR}"/mosquitto
- insinto /etc/mosquitto
- doins mosquitto.conf
- insinto /usr/share/mosquitto
- doins misc/letsencrypt/mosquitto-copy.sh
- systemd_newunit "${FILESDIR}/mosquitto.notify.service" mosquitto.service
-
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- dodoc -r examples
- fi
-}
-
-pkg_postinst() {
- for v in ${REPLACING_VERSIONS}; do
- if [[ $(ver_cut 1 "$v") -lt 2 ]]; then
- elog
- elog "Please read the migration guide at:"
- elog "https://mosquitto.org/documentation/migrating-to-2-0/"
- elog
- elog "If you use Lets Encrypt TLS certificates, take note of"
- elog "the changes required to run the daemon as the unprivileged"
- elog "mosquitto user. The mosquitto-copy.sh script has been"
- elog "installed to /usr/share/mosquitto/ for your convenience."
- elog
- fi
- done
-}
diff --git a/app-misc/mosquitto/mosquitto-2.0.17.ebuild b/app-misc/mosquitto/mosquitto-2.0.17.ebuild
deleted file mode 100644
index fdefe0ec14b1..000000000000
--- a/app-misc/mosquitto/mosquitto-2.0.17.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit python-any-r1 systemd toolchain-funcs
-
-DESCRIPTION="An Open Source MQTT v3 Broker"
-HOMEPAGE="https://mosquitto.org/ https://github.com/eclipse/mosquitto"
-SRC_URI="https://mosquitto.org/files/source/${P}.tar.gz"
-
-LICENSE="EPL-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="bridge examples +persistence +srv ssl systemd tcpd test websockets"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="test? ( bridge )"
-
-RDEPEND="
- acct-user/mosquitto
- acct-group/mosquitto
- dev-libs/cJSON:=
- srv? ( net-dns/c-ares:= )
- ssl? (
- dev-libs/openssl:0=
- )
- systemd? ( sys-apps/systemd )
- tcpd? ( sys-apps/tcp-wrappers )
- websockets? ( net-libs/libwebsockets[lejp] )
-"
-DEPEND="
- ${RDEPEND}
- test? ( dev-util/cunit )
-"
-BDEPEND="
- test? ( ${PYTHON_DEPS} )
-"
-
-pkg_setup() {
- use test && python_setup
-}
-
-_emake() {
- local LIBDIR=$(get_libdir)
- emake \
- CC="$(tc-getCC)" \
- CXX="$(tc-getCXX)" \
- CLIENT_LDFLAGS="${LDFLAGS}" \
- LIB_SUFFIX="${LIBDIR:3}" \
- WITH_BRIDGE="$(usex bridge)" \
- WITH_PERSISTENCE="$(usex persistence)" \
- WITH_SRV="$(usex srv)" \
- WITH_SYSTEMD="$(usex systemd)" \
- WITH_TLS="$(usex ssl)" \
- WITH_WEBSOCKETS="$(usex websockets)" \
- WITH_WRAP="$(usex tcpd)" \
- "$@"
-}
-
-src_prepare() {
- default
- if use persistence; then
- sed -i -e "/^#autosave_interval/s|^#||" \
- -e "s|^#persistence false$|persistence true|" \
- -e "/^#persistence_file/s|^#||" \
- -e "s|#persistence_location|persistence_location /var/lib/mosquitto/|" \
- mosquitto.conf || die
- fi
-
- # Remove failing tests
- sed -i \
- -e '/06-bridge-reconnect-local-out.py/d' \
- test/broker/Makefile || die
- sed -i \
- -e '/02-subscribe-qos1-async2.test/d' \
- test/lib/Makefile || die
-
- # Extend test timeout to prevent spurious failures
- sed -i -e 's/SUB_TIMEOUT=1/SUB_TIMEOUT=3/' \
- test/client/test.sh || die
-
- use test && python_fix_shebang test
-}
-
-src_compile() {
- _emake
-}
-
-src_test() {
- _emake test
-}
-
-src_install() {
- _emake DESTDIR="${D}" prefix=/usr install
- keepdir /var/lib/mosquitto
- fowners mosquitto:mosquitto /var/lib/mosquitto
- dodoc README.md CONTRIBUTING.md ChangeLog.txt
- doinitd "${FILESDIR}"/mosquitto
- insinto /etc/mosquitto
- doins mosquitto.conf
- insinto /usr/share/mosquitto
- doins misc/letsencrypt/mosquitto-copy.sh
- systemd_newunit "${FILESDIR}/mosquitto.notify.service" mosquitto.service
-
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- dodoc -r examples
- fi
-}
-
-pkg_postinst() {
- for v in ${REPLACING_VERSIONS}; do
- if [[ $(ver_cut 1 "$v") -lt 2 ]]; then
- elog
- elog "Please read the migration guide at:"
- elog "https://mosquitto.org/documentation/migrating-to-2-0/"
- elog
- elog "If you use Lets Encrypt TLS certificates, take note of"
- elog "the changes required to run the daemon as the unprivileged"
- elog "mosquitto user. The mosquitto-copy.sh script has been"
- elog "installed to /usr/share/mosquitto/ for your convenience."
- elog
- fi
- done
-}