summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 00:20:01 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:30:32 -0400
commit847357bb2a3f289c30f77ae51f94589be5a4e509 (patch)
tree9aa3fc17e078e5b9ce993abff9a83c5d340c7542 /app-misc
parentapp-i18n/kinput2: force gcc -E for imake's generation (diff)
downloadgentoo-847357bb2a3f289c30f77ae51f94589be5a4e509.tar.gz
gentoo-847357bb2a3f289c30f77ae51f94589be5a4e509.tar.bz2
gentoo-847357bb2a3f289c30f77ae51f94589be5a4e509.zip
app-misc/oneko: force gcc -E for imake's generation
Requires traditional cpp support and is broken in all sort of ways with clang-cpp / -E. Can still use clang & friends for everything else. Ideally these packages need to be built another way or last rited, imake will just accumulate more problems. Closes: https://bugs.gentoo.org/829092 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/oneko/oneko-1.2_p6_p14-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-misc/oneko/oneko-1.2_p6_p14-r1.ebuild b/app-misc/oneko/oneko-1.2_p6_p14-r1.ebuild
index 6e1677c1aeee..67e65e606266 100644
--- a/app-misc/oneko/oneko-1.2_p6_p14-r1.ebuild
+++ b/app-misc/oneko/oneko-1.2_p6_p14-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -27,6 +27,7 @@ DEPEND="
"
BDEPEND="
app-text/rman
+ sys-devel/gcc
x11-misc/gccmakedep
>=x11-misc/imake-1.0.8-r1
"
@@ -45,7 +46,7 @@ src_prepare() {
src_configure() {
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf -a || die
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf -a || die
}
src_compile() {