summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-mobilephone/bitpim
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-mobilephone/bitpim')
-rw-r--r--app-mobilephone/bitpim/Manifest1
-rw-r--r--app-mobilephone/bitpim/bitpim-1.0.6-r2.ebuild150
-rw-r--r--app-mobilephone/bitpim/files/bitpim-1.0.6-ffmpeg_quality.patch12
-rw-r--r--app-mobilephone/bitpim/files/bitpim-1.0.6-gcc43.patch22
-rw-r--r--app-mobilephone/bitpim/files/bitpim-1.0.6-gentoo.patch90
-rwxr-xr-xapp-mobilephone/bitpim/files/maketarball30
-rw-r--r--app-mobilephone/bitpim/metadata.xml11
7 files changed, 316 insertions, 0 deletions
diff --git a/app-mobilephone/bitpim/Manifest b/app-mobilephone/bitpim/Manifest
new file mode 100644
index 000000000000..bd2801c695cf
--- /dev/null
+++ b/app-mobilephone/bitpim/Manifest
@@ -0,0 +1 @@
+DIST bitpim-1.0.6.tar.bz2 4595216 SHA256 9a46b965e505d5a25bb613cef887bf23871f7b1c20493786cd0b880e3ef6855d SHA512 6ef4f56e1afa360b60a4522e6c0dc3526bf30e43d8ad783c247724c7cc212056cdb2664da09b0b5883e0eb38ed68d046f259043bf9b34ad0aa51773119c49c74 WHIRLPOOL 3cd092067d5fd11d325208f0e670135e28aa5aa2de769ffca7eaee7d8d339c55c036d4dbc2b0c34601fee11f78f0d0466c749f17ae02c5dd033935cd8dc5572f
diff --git a/app-mobilephone/bitpim/bitpim-1.0.6-r2.ebuild b/app-mobilephone/bitpim/bitpim-1.0.6-r2.ebuild
new file mode 100644
index 000000000000..7cf0764a0d35
--- /dev/null
+++ b/app-mobilephone/bitpim/bitpim-1.0.6-r2.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils fdo-mime multilib
+
+DESCRIPTION="Program to view and manipulate data on LG VX4400/VX6000 and many Sanyo Sprint mobile phones"
+HOMEPAGE="http://www.bitpim.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# this needs fixing
+#KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="crypt evo usb"
+
+COMMON_DEPEND="dev-python/apsw[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/python-dsv[${PYTHON_USEDEP}]
+ dev-python/wxpython:2.8[${PYTHON_USEDEP}]
+ crypt? (
+ >=dev-python/paramiko-1.7.1[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+ usb? ( virtual/libusb:0 )"
+DEPEND="${COMMON_DEPEND}
+ usb? ( dev-lang/swig )"
+RDEPEND="${COMMON_DEPEND}
+ media-libs/netpbm
+ virtual/ffmpeg"
+
+PATCHES=( "${FILESDIR}/${P}-gentoo.patch" "${FILESDIR}/${P}-ffmpeg_quality.patch" "${FILESDIR}/${P}-gcc43.patch" )
+
+src_prepare() {
+ distutils-r1_src_prepare
+ python_setup
+ sed -i -e "s/^PYTHONVER=.*/PYTHONVER=\$PYTHON/" \
+ src/native/usb/build.sh || die "sed failed"
+ sed -i "s/\$(EXTRADEFINES)\ -O2/\$(CXXFLAGS) \$(LDFLAGS)/" \
+ src/native/av/bmp2avi/Makefile || die "sed failed"
+}
+
+src_compile() {
+ # USB stuff
+ if use usb; then
+ cd "${S}/src/native/usb"
+ sh ./build.sh || die "compilation of native/usb failed"
+ fi
+
+ # strings
+ cd "${S}/src/native/strings"
+ distutils-r1_src_compile
+
+ # bmp2avi
+ cd "${S}/src/native/av/bmp2avi"
+ PLATFORM=linux emake CXX="$(tc-getCXX)"
+}
+
+src_install() {
+
+ # Install files into right place
+ #
+ # BitPim is a self-contained app, so jamming it into
+ # Python's site-packages might not be worthwhile. We'll
+ # Put it in its own home, and add the PYTHONPATH in the
+ # wrapper executables below.
+ local RLOC=/usr/$(get_libdir)/${P}
+
+ # Main Python source
+ insinto ${RLOC}
+ doins src/*.py
+
+ # Phone specifics
+ insinto ${RLOC}/phones
+ doins src/phones/*.py
+
+ # Native products
+ insinto ${RLOC}/native
+ doins src/native/*.py
+ insinto ${RLOC}/native/qtopiadesktop
+ doins src/native/qtopiadesktop/*.py
+ insinto ${RLOC}/native/outlook
+ doins src/native/outlook/*.py
+ insinto ${RLOC}/native/egroupware
+ doins src/native/egroupware/*.py
+ if use evo ; then
+ insinto ${RLOC}/native/evolution
+ doins src/native/evolution/*.py
+ fi
+
+ # strings
+ cd "${S}/src/native/strings"
+ distutils-r1_src_install
+
+ cd "${S}"
+ insinto $RLOC/native/strings
+ doins src/native/strings/__init__.py src/native/strings/jarowpy.py
+
+ # usb
+ if use usb; then
+ insinto ${RLOC}/native/usb
+ doins src/native/usb/*.py
+ doins src/native/usb/*.so
+ fi
+
+ # Helpers and resources
+ dobin src/native/av/bmp2avi/bmp2avi
+ insinto ${RLOC}/resources
+ doins resources/*
+
+ # Bitfling
+ if use crypt; then
+ FLINGDIR="${RLOC}/bitfling"
+ insinto $FLINGDIR
+ cd "${S}/src/bitfling"
+ doins *.py
+ cd "${S}"
+ fi
+
+ # Creating scripts
+ echo '#!/bin/sh' > "${T}/bitpim"
+ echo "exec $PYTHON ${RLOC}/bp.py \"\$@\"" >> "${T}/bitpim"
+ dobin "${T}/bitpim"
+ if use crypt; then
+ echo '#!/bin/sh' > "${T}/bitfling"
+ echo "exec $PYTHON ${RLOC}/bp.py \"\$@\" bitfling" >> "${T}/bitfling"
+ dobin "${T}/bitfling"
+ fi
+
+ # Desktop file
+ sed -i \
+ -e "s|%%INSTALLBINDIR%%|/usr/bin|" \
+ -e "s|%%INSTALLLIBDIR%%|${RLOC}|" \
+ -e "s|Terminal=0|Terminal=true|" \
+ -e "s|Application;Calendar;ContactManagement;Utility;|Calendar;ContactManagement;Utility;|" \
+ packaging/bitpim.desktop || die "sed failed"
+ domenu packaging/bitpim.desktop
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/app-mobilephone/bitpim/files/bitpim-1.0.6-ffmpeg_quality.patch b/app-mobilephone/bitpim/files/bitpim-1.0.6-ffmpeg_quality.patch
new file mode 100644
index 000000000000..2a5b7cb5237b
--- /dev/null
+++ b/app-mobilephone/bitpim/files/bitpim-1.0.6-ffmpeg_quality.patch
@@ -0,0 +1,12 @@
+diff -Nru bitpim-1.0.6.orig/src/conversions.py bitpim-1.0.6/src/conversions.py
+--- bitpim-1.0.6.orig/src/conversions.py 2008-11-02 13:51:31.000000000 +0000
++++ bitpim-1.0.6/src/conversions.py 2008-11-02 13:52:21.000000000 +0000
+@@ -239,7 +239,7 @@
+ ffmpeg=gethelperbinary("ffmpeg")
+ with common.usetempfile('mp3') as mp3file:
+ try:
+- run(ffmpeg, "-i", shortfilename(inputfilename), "-hq", "-ab", `bitrate`, "-ar", `samplerate`, "-ac", `channels`, shortfilename(mp3file))
++ run(ffmpeg, "-i", shortfilename(inputfilename), "-sameq", "-ab", `bitrate`, "-ar", `samplerate`, "-ac", `channels`, shortfilename(mp3file))
+ except common.CommandExecutionFailed, e:
+ # we get this exception on bad parameters, or any other
+ # issue so we assume bad parameters for the moment.
diff --git a/app-mobilephone/bitpim/files/bitpim-1.0.6-gcc43.patch b/app-mobilephone/bitpim/files/bitpim-1.0.6-gcc43.patch
new file mode 100644
index 000000000000..dfb02d931a7a
--- /dev/null
+++ b/app-mobilephone/bitpim/files/bitpim-1.0.6-gcc43.patch
@@ -0,0 +1,22 @@
+diff -Nru bitpim-1.0.6.orig/src/native/av/bmp2avi/avi_file.cxx bitpim-1.0.6/src/native/av/bmp2avi/avi_file.cxx
+--- bitpim-1.0.6.orig/src/native/av/bmp2avi/avi_file.cxx 2005-02-18 06:55:03.000000000 +0000
++++ bitpim-1.0.6/src/native/av/bmp2avi/avi_file.cxx 2008-11-02 13:54:15.000000000 +0000
+@@ -9,6 +9,7 @@
+
+ #include "avi_file.h"
+ #include "byte_order.h"
++#include <cstring>
+
+ // endian conversion routines
+
+diff -Nru bitpim-1.0.6.orig/src/native/av/bmp2avi/bmp_file.cxx bitpim-1.0.6/src/native/av/bmp2avi/bmp_file.cxx
+--- bitpim-1.0.6.orig/src/native/av/bmp2avi/bmp_file.cxx 2005-02-18 06:55:03.000000000 +0000
++++ bitpim-1.0.6/src/native/av/bmp2avi/bmp_file.cxx 2008-11-02 13:54:15.000000000 +0000
+@@ -11,6 +11,7 @@
+ #include <string>
+ #include "bmp_file.h"
+ #include "byte_order.h"
++#include <cstring>
+
+ using namespace std;
+
diff --git a/app-mobilephone/bitpim/files/bitpim-1.0.6-gentoo.patch b/app-mobilephone/bitpim/files/bitpim-1.0.6-gentoo.patch
new file mode 100644
index 000000000000..ed7f96e62898
--- /dev/null
+++ b/app-mobilephone/bitpim/files/bitpim-1.0.6-gentoo.patch
@@ -0,0 +1,90 @@
+diff -Nru bitpim-1.0.6.orig/src/common.py bitpim-1.0.6/src/common.py
+--- bitpim-1.0.6.orig/src/common.py 2007-08-29 00:19:51.000000000 +0000
++++ bitpim-1.0.6/src/common.py 2008-11-02 13:50:39.000000000 +0000
+@@ -860,7 +860,7 @@
+ # windows running from exe, return as is
+ return os.path.abspath(os.path.dirname(sys.executable))
+ # running from src, up one
+- return os.path.split(os.path.abspath(os.path.dirname(sys.argv[0])))[0]
++ return os.path.abspath(os.path.dirname(sys.argv[0]))
+
+ if sys.platform=='win32':
+ # From Tim Golden's Win32 How Do I ...?
+diff -Nru bitpim-1.0.6.orig/src/conversions.py bitpim-1.0.6/src/conversions.py
+--- bitpim-1.0.6.orig/src/conversions.py 2007-08-29 00:19:51.000000000 +0000
++++ bitpim-1.0.6/src/conversions.py 2008-11-02 13:50:39.000000000 +0000
+@@ -23,11 +23,11 @@
+
+ class ConversionFailed(Exception): pass
+
+-helperdir=os.path.join(common.get_main_dir(), "helpers")
++helperdir="/usr/bin"
+
+ osext={'win32': '.exe',
+ 'darwin': '.mbin',
+- 'linux2': '.lbin'} \
++ 'linux2': ''} \
+ [sys.platform]
+
+ # This shortname crap is needed because Windows programs (including ffmpeg)
+@@ -128,14 +128,14 @@
+ p=sys.path[0]
+ if os.path.isfile(p):
+ p=os.path.dirname(p)
+- helpersdirectory=os.path.abspath(os.path.join(p, 'helpers'))
++ helpersdirectory="/usr/bin"
+ print "Helper Directory: "+helpersdirectory
+ if sys.platform=='win32':
+ osext=".exe"
+ if sys.platform=='darwin':
+ osext=".mbin"
+ if sys.platform=='linux2':
+- osext=".lbin"
++ osext=""
+
+ pngtopnmbin=gethelperbinary('pngtopnm')
+ ppmquantbin=gethelperbinary('ppmquant')
+diff -Nru bitpim-1.0.6.orig/src/importexport.py bitpim-1.0.6/src/importexport.py
+--- bitpim-1.0.6.orig/src/importexport.py 2007-08-27 04:58:33.000000000 +0000
++++ bitpim-1.0.6/src/importexport.py 2008-11-02 13:50:39.000000000 +0000
+@@ -23,7 +23,7 @@
+ import wx.html
+
+ # Others
+-from thirdparty import DSV
++import DSV
+
+ # My modules
+ import common
+diff -Nru bitpim-1.0.6.orig/src/native/av/bmp2avi/Makefile bitpim-1.0.6/src/native/av/bmp2avi/Makefile
+--- bitpim-1.0.6.orig/src/native/av/bmp2avi/Makefile 2006-05-05 07:10:08.000000000 +0000
++++ bitpim-1.0.6/src/native/av/bmp2avi/Makefile 2008-11-02 13:50:39.000000000 +0000
+@@ -13,6 +13,6 @@
+
+ SRC=avi_file.cxx bmp_file.cxx b2a.cxx
+
+-bmp2avi.lbin bmp2avi.mbin bmp2avi.exe: $(SRC)
++bmp2avi bmp2avi.mbin bmp2avi.exe: $(SRC)
+ $(CXX) $(EXTRADEFINES) -O2 -o $@ $(SRC)
+
+diff -Nru bitpim-1.0.6.orig/src/native/usb/build.sh bitpim-1.0.6/src/native/usb/build.sh
+--- bitpim-1.0.6.orig/src/native/usb/build.sh 2007-08-10 21:53:59.000000000 +0000
++++ bitpim-1.0.6/src/native/usb/build.sh 2008-11-02 13:50:39.000000000 +0000
+@@ -4,4 +4,4 @@
+ swig -python -I/usr/include libusb.i
+
+ gcc -fPIC -Wall -fno-strict-aliasing -O2 -g -shared -I $INCLUDEDIR -o _libusb.so libusb_wrap.c -lusb
+-strip _libusb.so
++#strip _libusb.so
+diff -Nru bitpim-1.0.6.orig/src/phones/com_samsung.py bitpim-1.0.6/src/phones/com_samsung.py
+--- bitpim-1.0.6.orig/src/phones/com_samsung.py 2007-08-17 21:11:59.000000000 +0000
++++ bitpim-1.0.6/src/phones/com_samsung.py 2008-11-02 13:50:39.000000000 +0000
+@@ -16,7 +16,7 @@
+ import time
+
+ # site-packages
+-from thirdparty import DSV
++import DSV
+
+ # BitPim modules
+ import bpcalendar
diff --git a/app-mobilephone/bitpim/files/maketarball b/app-mobilephone/bitpim/files/maketarball
new file mode 100755
index 000000000000..8df7f071df9a
--- /dev/null
+++ b/app-mobilephone/bitpim/files/maketarball
@@ -0,0 +1,30 @@
+# For building the tarball. To be used only by ebuild maintainers
+DISTDIR=/usr/portage/distfiles
+PN=bitpim
+PV=$1
+P=$PN-$PV
+
+if [ -z "$PV" ]; then
+ echo "usage: $0 version"
+else
+ svnrev=$(svn log -q --limit 1 https://${PN}.svn.sourceforge.net/svnroot/${PN}/releases/${PV} | sed -r '/^[^r]/d;s/^r([0-9]+) .*$/\1/')
+ [ $? = 0 ] || return 1
+
+ #Fetch the source (only those directories that are needed)
+ cd "${DISTDIR}" && mkdir -p ${P} || return 1
+ for x in resources packaging src ; do
+ svn export https://${PN}.svn.sourceforge.net/svnroot/${PN}/releases/${PV}/${x} ${P}/${x} || return 1
+ done
+
+ #Remove unneeded stuff
+ rm ${P}/resources/*.chm ${P}/src/package.py
+
+ #Freeze version and set vendor name to Gentoo
+ sed -i -e 's/\(^__FROZEN__="[$]Id: \).*\( $"\)/\1'${svnrev}'\2/' \
+ -e 's/^vendor=".*"/vendor="Gentoo"/' \
+ ${P}/src/version.py || return 1
+
+ #Make the tarball
+ tar -cjf ${P}.tar.bz2 ${P}
+ rm -r ${P}
+fi
diff --git a/app-mobilephone/bitpim/metadata.xml b/app-mobilephone/bitpim/metadata.xml
new file mode 100644
index 000000000000..fbcc8e10b031
--- /dev/null
+++ b/app-mobilephone/bitpim/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version = '1.0' encoding = 'UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+ <longdescription>
+ BitPim is a program that allows you to view and manipulate data on LG
+ VX4400/VX6000 and many Sanyo Sprint cell phones. This includes the
+ PhoneBook, Calendar, WallPapers, RingTones (functionality varies by
+ phone) and the Filesystem for most Qualcomm CDMA chipset based phones.
+ </longdescription>
+</pkgmetadata>