summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-03 10:31:42 +0000
committerSam James <sam@gentoo.org>2024-01-03 10:39:51 +0000
commit52c53b39cde723e70083e979f2b006322f302ecb (patch)
treecc93cd3cf76ba970137c93db59105c17f62e544a /app-office/libreoffice
parentsys-libs/zlib: pass -Wl,--undefined-version for other linkers if supported (diff)
downloadgentoo-52c53b39cde723e70083e979f2b006322f302ecb.tar.gz
gentoo-52c53b39cde723e70083e979f2b006322f302ecb.tar.bz2
gentoo-52c53b39cde723e70083e979f2b006322f302ecb.zip
app-office/libreoffice: pass -Wl,--undefined-version for other linkers if supported
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office/libreoffice')
-rw-r--r--app-office/libreoffice/libreoffice-7.5.6.2.ebuild8
-rw-r--r--app-office/libreoffice/libreoffice-7.5.8.2-r2.ebuild8
-rw-r--r--app-office/libreoffice/libreoffice-7.5.8.2.ebuild8
-rw-r--r--app-office/libreoffice/libreoffice-7.5.9.2.ebuild8
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild8
5 files changed, 20 insertions, 20 deletions
diff --git a/app-office/libreoffice/libreoffice-7.5.6.2.ebuild b/app-office/libreoffice/libreoffice-7.5.6.2.ebuild
index 9d2b564c853d..7ec34f336fdf 100644
--- a/app-office/libreoffice/libreoffice-7.5.6.2.ebuild
+++ b/app-office/libreoffice/libreoffice-7.5.6.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -395,6 +395,9 @@ src_configure() {
einfo "Preset CFLAGS: ${CFLAGS}"
einfo "Preset LDFLAGS: ${LDFLAGS}"
+ # Workaround for bug #915067
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
if use clang ; then
# Force clang
einfo "Enforcing the use of clang due to USE=clang ..."
@@ -408,9 +411,6 @@ src_configure() {
# Workaround for bug #907905
filter-lto
- # Workaround for bug #915067
- append-ldflags -Wl,--undefined-version
-
# Not implemented by Clang, bug #903889
filter-flags -Wlto-type-mismatch -Werror=lto-type-mismatch
else
diff --git a/app-office/libreoffice/libreoffice-7.5.8.2-r2.ebuild b/app-office/libreoffice/libreoffice-7.5.8.2-r2.ebuild
index 2d1d90c37611..984ca1c390bb 100644
--- a/app-office/libreoffice/libreoffice-7.5.8.2-r2.ebuild
+++ b/app-office/libreoffice/libreoffice-7.5.8.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -405,6 +405,9 @@ src_configure() {
einfo "Preset CFLAGS: ${CFLAGS}"
einfo "Preset LDFLAGS: ${LDFLAGS}"
+ # Workaround for bug #915067
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
if use clang ; then
# Force clang
einfo "Enforcing the use of clang due to USE=clang ..."
@@ -418,9 +421,6 @@ src_configure() {
# Workaround for bug #907905
filter-lto
- # Workaround for bug #915067
- append-ldflags -Wl,--undefined-version
-
# Not implemented by Clang, bug #903889
filter-flags -Wlto-type-mismatch -Werror=lto-type-mismatch
else
diff --git a/app-office/libreoffice/libreoffice-7.5.8.2.ebuild b/app-office/libreoffice/libreoffice-7.5.8.2.ebuild
index b346307b840c..c0a3d703ff40 100644
--- a/app-office/libreoffice/libreoffice-7.5.8.2.ebuild
+++ b/app-office/libreoffice/libreoffice-7.5.8.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -398,6 +398,9 @@ src_configure() {
einfo "Preset CFLAGS: ${CFLAGS}"
einfo "Preset LDFLAGS: ${LDFLAGS}"
+ # Workaround for bug #915067
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
if use clang ; then
# Force clang
einfo "Enforcing the use of clang due to USE=clang ..."
@@ -411,9 +414,6 @@ src_configure() {
# Workaround for bug #907905
filter-lto
- # Workaround for bug #915067
- append-ldflags -Wl,--undefined-version
-
# Not implemented by Clang, bug #903889
filter-flags -Wlto-type-mismatch -Werror=lto-type-mismatch
else
diff --git a/app-office/libreoffice/libreoffice-7.5.9.2.ebuild b/app-office/libreoffice/libreoffice-7.5.9.2.ebuild
index 64d3859995c9..c072a93b00e1 100644
--- a/app-office/libreoffice/libreoffice-7.5.9.2.ebuild
+++ b/app-office/libreoffice/libreoffice-7.5.9.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -404,6 +404,9 @@ src_configure() {
einfo "Preset CFLAGS: ${CFLAGS}"
einfo "Preset LDFLAGS: ${LDFLAGS}"
+ # Workaround for bug #915067
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
if use clang ; then
# Force clang
einfo "Enforcing the use of clang due to USE=clang ..."
@@ -417,9 +420,6 @@ src_configure() {
# Workaround for bug #907905
filter-lto
- # Workaround for bug #915067
- append-ldflags -Wl,--undefined-version
-
# Not implemented by Clang, bug #903889
filter-flags -Wlto-type-mismatch -Werror=lto-type-mismatch
else
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index 7eec09df7595..3341480b61da 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -395,6 +395,9 @@ src_configure() {
einfo "Preset CFLAGS: ${CFLAGS}"
einfo "Preset LDFLAGS: ${LDFLAGS}"
+ # Workaround for bug #915067
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
if use clang ; then
# Force clang
einfo "Enforcing the use of clang due to USE=clang ..."
@@ -408,9 +411,6 @@ src_configure() {
# Workaround for bug #907905
filter-lto
- # Workaround for bug #915067
- append-ldflags -Wl,--undefined-version
-
# Not implemented by Clang, bug #903889
filter-flags -Wlto-type-mismatch -Werror=lto-type-mismatch
else