summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-20 23:23:53 +0000
committerSam James <sam@gentoo.org>2022-02-20 23:27:41 +0000
commitad83a5e67b6aa68a71c2633b6008d6e8a5f8e962 (patch)
tree451c270fb1f9c64fc4fd1054db9eb28216a18394 /app-office
parentnet-analyzer/bwping: add 2.5 (diff)
downloadgentoo-ad83a5e67b6aa68a71c2633b6008d6e8a5f8e962.tar.gz
gentoo-ad83a5e67b6aa68a71c2633b6008d6e8a5f8e962.tar.bz2
gentoo-ad83a5e67b6aa68a71c2633b6008d6e8a5f8e962.zip
app-office/texstudio: add 4.2.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/texstudio/Manifest1
-rw-r--r--app-office/texstudio/texstudio-4.2.2.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-office/texstudio/Manifest b/app-office/texstudio/Manifest
index 7563d2d10436..4cf5554cfebd 100644
--- a/app-office/texstudio/Manifest
+++ b/app-office/texstudio/Manifest
@@ -3,3 +3,4 @@ DIST texstudio-4.1.1.tar.gz 88564492 BLAKE2B d3a198b4d355ea0f07391b8ff816baacd03
DIST texstudio-4.1.2.tar.gz 88666134 BLAKE2B 7c4310fd0d8fd446b8844f11c687f55818f7314a2e0614ac26b8023f8fa7e5eca1b60a3b3c0ce61ccb15d383b61c24280a67dd530a907b4b8e00a965b10230bf SHA512 0b88f82514462c363e6dcee899f3681883ce9db1bb21cbf9e5e657208338bba4a6cdb79feeaefb242350bc01b83851c5d2704a7d0e2888034070ef2588b77964
DIST texstudio-4.2.0.tar.gz 88795988 BLAKE2B da849849d9ab57cb04de63f24e207b03b47393b876cd2762277e00f17d39b8c19a7508df567642faec8a5ac10400d2a6327343b40ab076f24f0bc8bb1b2ec683 SHA512 aff5ae645a3b3c362e0456270576770c5b39212902a37633b7279476cf6278ee292ef93c4a0c917b1d4d513aaf597d634f4cf7a469fd4e918f35ddbbe5cb1700
DIST texstudio-4.2.1.tar.gz 88906345 BLAKE2B 045166fe73270013f9bff4965e3c1177c23b2419a2533144e069c6cc0f37ee729a816f9cdbc3baaf1ff0f936ef39d6bf5200b1ee89dabf43374860f52890b44f SHA512 2a3e435b7ac0ae2ce317b0de31f525c02bea39917b4ec5740f293109e09325008dfc174da41412c491376226f4cf458bd91e2d92f8b15cf4f3e41d82bc205bb4
+DIST texstudio-4.2.2.tar.gz 89234106 BLAKE2B a54b632ca6cf87410164f0a365f9a60b16cc51ea6ef12250b6ae6230ca7657615b3c91a88d995b2c654cbd42cda72b0e83af0b9471f87358f3f9a24270118d82 SHA512 b07dbe03b9b825fd2c6c057d996dad1247151d0034503d6e62426f0c4ff1e982da8eddf801e497bf9743349d41401ac9946f828c276f164aec0955c8324f5dea
diff --git a/app-office/texstudio/texstudio-4.2.2.ebuild b/app-office/texstudio/texstudio-4.2.2.ebuild
new file mode 100644
index 000000000000..25a2b9ebb237
--- /dev/null
+++ b/app-office/texstudio/texstudio-4.2.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop qmake-utils xdg
+
+MY_PV="${PV/_/}"
+DESCRIPTION="Free cross-platform LaTeX editor (fork from texmakerX)"
+HOMEPAGE="https://www.texstudio.org https://github.com/texstudio-org/texstudio"
+SRC_URI="https://github.com/texstudio-org/texstudio/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="video"
+
+DEPEND="
+ app-text/hunspell:=
+ app-text/poppler:=[qt5]
+ >=dev-libs/quazip-1.0:0=
+ dev-qt/designer:5
+ dev-qt/qtcore:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsingleapplication[qt5(+),X]
+ dev-qt/qtsvg:5
+ dev-qt/qttest:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ video? ( >=media-libs/phonon-4.11.0 )
+"
+RDEPEND="
+ ${DEPEND}
+ app-text/ghostscript-gpl
+ app-text/psutils
+ media-libs/netpbm
+ virtual/latex-base
+"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.5-quazip1.patch" # TODO: upstream
+)
+
+src_prepare() {
+ # TODO: find hunspell quazip utilities/poppler-data qtsingleapplication -delete || die
+ rm -r src/quazip || die
+
+ if use video; then
+ sed "/^PHONON/s:$:true:g" -i ${PN}.pro || die
+ fi
+
+ sed -e "/qtsingleapplication.pri/s/.*/CONFIG += qtsingleapplication/" \
+ -i ${PN}.pro || die
+ default
+}
+
+src_configure() {
+ eqmake5 USE_SYSTEM_HUNSPELL=1 USE_SYSTEM_QUAZIP=1 NO_TESTS=false
+}
+
+src_install() {
+ local i
+ for i in 16x16 22x22 32x32 48x48 64x64 128x128; do
+ newicon -s ${i} utilities/${PN}${i}.png ${PN}.png
+ done
+
+ emake DESTDIR="${D}" INSTALL_ROOT="${ED}" install
+
+ # We don't install licences per package
+ rm "${ED}"/usr/share/texstudio/COPYING || die
+}