summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-11-25 10:13:39 +0100
committerMichał Górny <mgorny@gentoo.org>2017-11-25 10:15:30 +0100
commit9edf53736568eaae0ecc7418678ca6521ae58b49 (patch)
treed3bc130fccb68e2890298eca229112e4cb5241c6 /app-portage
parentsys-kernel/ck-sources: v.bump (4.9.65 & 4.13.16 & 4.14.2) (diff)
downloadgentoo-9edf53736568eaae0ecc7418678ca6521ae58b49.tar.gz
gentoo-9edf53736568eaae0ecc7418678ca6521ae58b49.tar.bz2
gentoo-9edf53736568eaae0ecc7418678ca6521ae58b49.zip
app-portage/gemato: Add v4 release
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-4.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
new file mode 100644
index 000000000000..5c888b6b8c48
--- /dev/null
+++ b/app-portage/gemato/Manifest
@@ -0,0 +1 @@
+DIST gemato-4.tar.gz 57334 BLAKE2B 5aad3950e8b7fcf42d088de3b9dd5ded5eaeeb3f91414c38b79eaa4afd4799ccb4084da8a8bdf1bec67b82de8dd09a4c2977f07932a4c63bc833916d184418eb SHA512 a6747a83020efe72ad356873b1648bcf80828efaf9248e17e46cf626f879ebb77571c28d4097ebe56f891a0c096a81feed84bacbd04b37e6a6ce5f0ec37d27ba
diff --git a/app-portage/gemato/gemato-4.ebuild b/app-portage/gemato/gemato-4.ebuild
new file mode 100644
index 000000000000..b5c0440f4f0a
--- /dev/null
+++ b/app-portage/gemato/gemato-4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# backports.lzma is broken with pypy
+# pyblake2 & pysha3 are broken with pypy3
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="https://github.com/mgorny/gemato/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+blake2 bzip2 +gpg lzma sha3"
+
+RDEPEND="
+ blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )
+ bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
+ gpg? ( app-crypt/gnupg )
+ lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
+ sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ "${PYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}