summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-13 15:55:08 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-13 15:55:08 +0200
commit137cdb5311f615f0c72bab5d9304a38612239f49 (patch)
tree773e6926e05639eb7798a30d5e397c514982a01d /app-shells/bash/bash-2.05b_p13.ebuild
parentapp-arch/unrar: drop unused flag-o-matic inherit (diff)
downloadgentoo-137cdb5311f615f0c72bab5d9304a38612239f49.tar.gz
gentoo-137cdb5311f615f0c72bab5d9304a38612239f49.tar.bz2
gentoo-137cdb5311f615f0c72bab5d9304a38612239f49.zip
app-shells/bash: drop unused multilib inherit, tidy up ebuild
* Drop unused multilib inherit * Move lost/orphaned ncurses comment to its rightful place * Normalise bug references * Add whitespace to aid readability Closes: https://github.com/gentoo/gentoo/pull/20538 Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-shells/bash/bash-2.05b_p13.ebuild')
-rw-r--r--app-shells/bash/bash-2.05b_p13.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/app-shells/bash/bash-2.05b_p13.ebuild b/app-shells/bash/bash-2.05b_p13.ebuild
index cdacaa870073..5d27c8bf42fa 100644
--- a/app-shells/bash/bash-2.05b_p13.ebuild
+++ b/app-shells/bash/bash-2.05b_p13.ebuild
@@ -47,18 +47,19 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${PN}-2.05b-destdir.patch
- "${FILESDIR}"/autoconf-mktime-2.53.patch #220040
+ "${FILESDIR}"/autoconf-mktime-2.53.patch # bug #220040
"${FILESDIR}"/${PN}-2.05b-protos.patch
"${FILESDIR}"/${PN}-2.05b-empty-herestring.patch
- "${FILESDIR}"/${PN}-2.05b-rbash.patch #26854
- "${FILESDIR}"/${PN}-2.05b-parallel-build.patch #41002
+ "${FILESDIR}"/${PN}-2.05b-rbash.patch # bug #26854
+ "${FILESDIR}"/${PN}-2.05b-parallel-build.patch # bug #41002
"${FILESDIR}"/${PN}-2.05b-jobs.patch
"${FILESDIR}"/${PN}-2.05b-fix-job-warning.patch
- "${FILESDIR}"/${PN}-3.1-dev-fd-buffer-overflow.patch #431850
+ "${FILESDIR}"/${PN}-3.1-dev-fd-buffer-overflow.patch # bug #431850
)
pkg_setup() {
- if is-flag -malign-double ; then #7332
+ # bug #7332
+ if is-flag -malign-double ; then
eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
eerror "as it breaks LFS (struct stat64) on x86."
die "remove -malign-double from your CFLAGS mr ricer"
@@ -84,7 +85,13 @@ src_prepare() {
src_configure() {
local myconf=(
--with-installed-readline=.
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses. For the most part, ncurses
+ # is here because readline needs it. But bash itself calls
+ # ncurses in one or two small places :(.
--with-curses
+
$(use_with afs)
$(use_enable net net-redirections)
--disable-profiling
@@ -121,16 +128,13 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=6.2
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses. For the most part, ncurses
- # is here because readline needs it. But bash itself calls
- # ncurses in one or two small places :(.
+ # bug #444070
+ tc-export AR
- tc-export AR #444070
# This old autoconf script does not re-exec itself properly and fails when
# /bin/sh is not bash. Rather than try to regen everything, just force the
# use of bash directly.
- CONFIG_SHELL="/bin/bash" econf "${myconf[@]}"
+ CONFIG_SHELL="${BROOT}/bin/bash" econf "${myconf[@]}"
}
src_install() {