summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-11 11:32:39 +0100
committerSam James <sam@gentoo.org>2024-08-11 11:32:39 +0100
commit76f10f547f002195b01bf3774050909acec767e1 (patch)
tree82750bd01bc1a061bf62cbb0433d6d23a94d2671 /app-shells/dash/dash-0.5.12.ebuild
parentprofiles/prefix: drop obsolete gentoo-functions mask for prefix (diff)
downloadgentoo-76f10f547f002195b01bf3774050909acec767e1.tar.gz
gentoo-76f10f547f002195b01bf3774050909acec767e1.tar.bz2
gentoo-76f10f547f002195b01bf3774050909acec767e1.zip
app-shells/dash: add 9999
dash releases are infrequent. Further, there's various POSIX.1-2024 changes in git which may be useful to test. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells/dash/dash-0.5.12.ebuild')
-rw-r--r--app-shells/dash/dash-0.5.12.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/app-shells/dash/dash-0.5.12.ebuild b/app-shells/dash/dash-0.5.12.ebuild
index 7659ef8d0f3b..951b11271623 100644
--- a/app-shells/dash/dash-0.5.12.ebuild
+++ b/app-shells/dash/dash-0.5.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,11 +7,16 @@ inherit flag-o-matic toolchain-funcs
DESCRIPTION="Debian Almquist Shell"
HOMEPAGE="http://gondor.apana.org.au/~herbert/dash/"
-SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${P}.tar.gz"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/utils/dash/dash.git"
+ inherit autotools git-r3
+else
+ SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${P}.tar.gz"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+fi
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="libedit static"
BDEPEND="virtual/pkgconfig"
@@ -27,6 +32,8 @@ src_prepare() {
# Fix the invalid sort
sed -i -e 's/LC_COLLATE=C/LC_ALL=C/g' src/mkbuiltins || die
+ [[ ${PV} == 9999 ]] && eautoreconf
+
# Use pkg-config for libedit linkage
sed -i \
-e "/LIBS/s:-ledit:\`$(tc-getPKG_CONFIG) --libs libedit $(usex static --static '')\`:" \