summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-08-30 00:25:17 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-08-30 00:26:37 +0200
commit8c667305d11032d81b0b598cc31cdb6d0796204c (patch)
treed503ea2bb53cece6b574f99c337ce63e62ef20e5 /app-shells
parentapp-shells/zsh: Bump to version 5.4.2 (diff)
downloadgentoo-8c667305d11032d81b0b598cc31cdb6d0796204c.tar.gz
gentoo-8c667305d11032d81b0b598cc31cdb6d0796204c.tar.bz2
gentoo-8c667305d11032d81b0b598cc31cdb6d0796204c.zip
app-shells/zsh: Sync live ebuild.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh/zsh-9999.ebuild34
1 files changed, 17 insertions, 17 deletions
diff --git a/app-shells/zsh/zsh-9999.ebuild b/app-shells/zsh/zsh-9999.ebuild
index 8919a5c5da5a..dfbabed7e84e 100644
--- a/app-shells/zsh/zsh-9999.ebuild
+++ b/app-shells/zsh/zsh-9999.ebuild
@@ -10,7 +10,7 @@ if [[ ${PV} == 9999* ]] ; then
EGIT_REPO_URI="git://git.code.sf.net/p/zsh/code"
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- SRC_URI="http://www.zsh.org/pub/${P}.tar.xz
+ SRC_URI="http://www.zsh.org/pub/${P}.tar.gz
doc? ( http://www.zsh.org/pub/${P}-doc.tar.xz )"
fi
@@ -74,7 +74,21 @@ src_prepare() {
}
src_configure() {
- local myconf=()
+ local myconf=(
+ --bindir="${EPREFIX}"/bin
+ --libdir="${EPREFIX}"/usr/$(get_libdir)
+ --enable-etcdir="${EPREFIX}"/etc/zsh
+ --enable-runhelpdir="${EPREFIX}"/usr/share/zsh/${PV%_*}/help
+ --enable-fndir="${EPREFIX}"/usr/share/zsh/${PV%_*}/functions
+ --enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions
+ --enable-function-subdirs
+ --with-tcsetpgrp
+ $(use_enable maildir maildir-support)
+ $(use_enable pcre)
+ $(use_enable caps cap)
+ $(use_enable unicode multibyte)
+ $(use_enable gdbm )
+ )
if use static ; then
myconf+=( --disable-dynamic )
@@ -95,21 +109,7 @@ src_configure() {
append-ldflags -Wl,-x
fi
- econf \
- --bindir="${EPREFIX}"/bin \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --enable-etcdir="${EPREFIX}"/etc/zsh \
- --enable-runhelpdir="${EPREFIX}"/usr/share/zsh/${PV%_*}/help \
- --enable-fndir="${EPREFIX}"/usr/share/zsh/${PV%_*}/functions \
- --enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions \
- --enable-function-subdirs \
- --with-tcsetpgrp \
- $(use_enable maildir maildir-support) \
- $(use_enable pcre) \
- $(use_enable caps cap) \
- $(use_enable unicode multibyte) \
- $(use_enable gdbm ) \
- "${myconf[@]}"
+ econf "${myconf[@]}"
if use static ; then
# compile all modules statically, see Bug #27392