summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/goldendict
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/goldendict')
-rw-r--r--app-text/goldendict/Manifest1
-rw-r--r--app-text/goldendict/files/goldendict-1.0.1-gcc-4.7.patch40
-rw-r--r--app-text/goldendict/goldendict-1.0.1.ebuild71
-rw-r--r--app-text/goldendict/metadata.xml13
4 files changed, 125 insertions, 0 deletions
diff --git a/app-text/goldendict/Manifest b/app-text/goldendict/Manifest
new file mode 100644
index 000000000000..1a5b715e2607
--- /dev/null
+++ b/app-text/goldendict/Manifest
@@ -0,0 +1 @@
+DIST goldendict-1.0.1-src.tar.bz2 2705932 SHA256 b3fb0405a5edb38f02ef881b48c36e46e2eacf641b0caf8d99403f595a4be9a6 SHA512 6c35f804063e14ffc9fe9fbd86e710582c550d10fcabb83e7fb0f65ccad1e18eaa31578a96f0aea67276453239b8035f5a694c7d081f9a6f7a822d2b75ebce55 WHIRLPOOL f642692c5ac921d031e89a4512ac63eb665d5b3d02f2a4aea911566131188f877c173d4624eef073e3580e30d8291c1f0196d870738daf2be469783838305c4c
diff --git a/app-text/goldendict/files/goldendict-1.0.1-gcc-4.7.patch b/app-text/goldendict/files/goldendict-1.0.1-gcc-4.7.patch
new file mode 100644
index 000000000000..24995a221b3c
--- /dev/null
+++ b/app-text/goldendict/files/goldendict-1.0.1-gcc-4.7.patch
@@ -0,0 +1,40 @@
+From b00d081da20b9a6b257573c6b23a6bc640c4dab1 Mon Sep 17 00:00:00 2001
+From: Michael Palimaka <kensington@gentoo.org>
+Date: Fri, 20 Jul 2012 03:27:38 +1000
+Subject: [PATCH] Fix build with GCC 4.7 by adding missing includes.
+
+---
+ processwrapper.cc | 4 ++++
+ qtsingleapplication/src/qtlocalpeer.cpp | 1 +
+ 2 files changed, 5 insertions(+)
+
+diff --git a/processwrapper.cc b/processwrapper.cc
+index f7f3f19..86b985d 100644
+--- a/processwrapper.cc
++++ b/processwrapper.cc
+@@ -2,6 +2,10 @@
+
+ #include <QtCore>
+
++#if defined(Q_OS_UNIX)
++#include <unistd.h>
++#endif
++
+ #ifdef Q_OS_WIN32
+
+ #include <windows.h>
+diff --git a/qtsingleapplication/src/qtlocalpeer.cpp b/qtsingleapplication/src/qtlocalpeer.cpp
+index 382d182..506c142 100644
+--- a/qtsingleapplication/src/qtlocalpeer.cpp
++++ b/qtsingleapplication/src/qtlocalpeer.cpp
+@@ -50,6 +50,7 @@ static PProcessIdToSessionId pProcessIdToSessionId = 0;
+ #endif
+ #if defined(Q_OS_UNIX)
+ #include <time.h>
++#include <unistd.h>
+ #endif
+
+ namespace QtLP_Private {
+--
+1.7.11.1
+
diff --git a/app-text/goldendict/goldendict-1.0.1.ebuild b/app-text/goldendict/goldendict-1.0.1.ebuild
new file mode 100644
index 000000000000..c4c1adab7a20
--- /dev/null
+++ b/app-text/goldendict/goldendict-1.0.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PLOCALES="ar_SA bg_BG cs_CZ de_DE el_GR it_IT lt_LT ru_RU uk_UA vi_VN zh_CN"
+
+inherit l10n qt4-r2
+
+DESCRIPTION="Feature-rich dictionary lookup program"
+HOMEPAGE="http://goldendict.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug kde"
+
+RDEPEND="
+ >=app-text/hunspell-1.2
+ media-libs/libogg
+ media-libs/libvorbis
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXtst
+ >=dev-qt/qtcore-4.5:4[exceptions,qt3support]
+ >=dev-qt/qtgui-4.5:4[exceptions,qt3support]
+ >=dev-qt/qtwebkit-4.5:4[exceptions]
+ !kde? ( || (
+ >=dev-qt/qtphonon-4.5:4[exceptions]
+ media-libs/phonon[qt4]
+ ) )
+ kde? ( media-libs/phonon[qt4] )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}
+
+PATCHES=( "${FILESDIR}/${P}-gcc-4.7.patch" )
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ l10n_for_each_disabled_locale_do editpro
+
+ # do not install duplicates
+ sed -e '/[icon,desktop]s2/d' -i ${PN}.pro || die
+
+ # fix desktop file
+ sed -e '/^Categories=/s/;Applications$/;/' -i redist/${PN}.desktop || die
+}
+
+src_configure() {
+ PREFIX="${EPREFIX}"/usr eqmake4
+}
+
+src_install() {
+ qt4-r2_src_install
+ l10n_for_each_locale_do insqm
+}
+
+editpro() {
+ sed -e "s;locale/${1}.ts;;" -i ${PN}.pro || die
+}
+
+insqm() {
+ insinto /usr/share/apps/${PN}/locale
+ doins locale/${1}.qm
+}
diff --git a/app-text/goldendict/metadata.xml b/app-text/goldendict/metadata.xml
new file mode 100644
index 000000000000..c438ed871d3a
--- /dev/null
+++ b/app-text/goldendict/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>nikoli@gmx.us</email>
+ <name>Nikoli</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">goldendict</remote-id>
+ </upstream>
+</pkgmetadata>