summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-30 12:06:57 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-30 12:49:36 +0200
commitb94d300c95e411ee4244605d4ebd9e4f1cf226c4 (patch)
treeb7f8c484a98d82d4ca174d943ed2e307df603a9c /app-text/gspell
parentapp-text/gspell: Drop old (diff)
downloadgentoo-b94d300c95e411ee4244605d4ebd9e4f1cf226c4.tar.gz
gentoo-b94d300c95e411ee4244605d4ebd9e4f1cf226c4.tar.bz2
gentoo-b94d300c95e411ee4244605d4ebd9e4f1cf226c4.zip
app-text/gspell: Version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-text/gspell')
-rw-r--r--app-text/gspell/Manifest1
-rw-r--r--app-text/gspell/gspell-1.0.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-text/gspell/Manifest b/app-text/gspell/Manifest
index 8c1eb8fd2eef..5b059b5714e9 100644
--- a/app-text/gspell/Manifest
+++ b/app-text/gspell/Manifest
@@ -1,2 +1,3 @@
DIST gspell-0.1.2.tar.xz 355128 SHA256 e8625c57296b6c178bc37659f023342f8edefaaa2c5eccf40de8bd479dbfa8f0 SHA512 8d9bd61f378929217b9461debb58df5070952539f30f6ee211cf13f856dfe5d5216468679a8d7d7b08df47ee6b7b45f25b2b6400212a83de9563e2bf175905bb WHIRLPOOL 44334ac608e9a66c5a6bf011ad21d7d368e29d7923079e947ed5484ae0c7847df1f29dc255979d0da844e1ecba16fa19dfae5b84aefd85287bc63de1465d3ffa
DIST gspell-1.0.2.tar.xz 383844 SHA256 80d859a2ee7cf5184bd2b3dc696a0ec1b899ff67b606177e1ef87ef945ff92bb SHA512 67ed34b70ca1d8e626f366b62847c04efe204fa21d9e6b3f55ec4d08dca8613f2a03e42de28d38ebe53923889d848ea9064f01a89ede9a7f22772712f5b11aa7 WHIRLPOOL 5ff3ea3925d0b44c2b6302c679fcd307823454d1f6e76484ddbcde76354bcc1d4a03bc833319a22974c535bdecc75444eb4ea09a0190865bfe4fa5739a6105bd
+DIST gspell-1.0.3.tar.xz 385772 SHA256 d95905e6c631e34911e8e3feeb364815bf3fd7ccd1dac118a34bcbae70261bd5 SHA512 c38159a988996c69ffd4ed7a348ab5eeef214632e57cf599541806b4317937f0f9ccb8d677182886fd281eb1a955cae595e6382924b1bd5f5edbe447b3e95e5b WHIRLPOOL c4dad122007264fe4a61039eb7aa38b04e4325fb3bf0916ddbcd1073988fe3acc13a9fe445023c113b87ea2ff59f93719d2efaa905d522aff5b070129098569b
diff --git a/app-text/gspell/gspell-1.0.3.ebuild b/app-text/gspell/gspell-1.0.3.ebuild
new file mode 100644
index 000000000000..c671014ce61f
--- /dev/null
+++ b/app-text/gspell/gspell-1.0.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="Spell check library for GTK+ applications"
+HOMEPAGE="https://wiki.gnome.org/Projects/gspell"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/1" # subslot = libgspell-1 soname version
+KEYWORDS="~alpha ~amd64 ~x86"
+
+IUSE="+introspection vala"
+REQUIRED_IUSE="vala? ( introspection )"
+
+RDEPEND="
+ app-text/iso-codes
+ >=app-text/enchant-1.6.0
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+ vala? ( $(vala_depend) )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.25
+ >=dev-util/intltool-0.35.0
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx emake check
+}