summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/keepnote
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/keepnote')
-rw-r--r--app-text/keepnote/Manifest1
-rw-r--r--app-text/keepnote/files/keepnote-0.7.8-desktopfile.patch30
-rw-r--r--app-text/keepnote/keepnote-0.7.9-r2.ebuild47
-rw-r--r--app-text/keepnote/metadata.xml23
4 files changed, 101 insertions, 0 deletions
diff --git a/app-text/keepnote/Manifest b/app-text/keepnote/Manifest
new file mode 100644
index 000000000000..c2ab4653b206
--- /dev/null
+++ b/app-text/keepnote/Manifest
@@ -0,0 +1 @@
+DIST keepnote-0.7.9.tar.gz 786634 SHA256 a57f329867ab93eae156392fee7ab77a754c4fdde5bab986b74415c6932ff8dc SHA512 1d818fab1fea69b6369209dbaad403b2431352ba359d4f233ab412fd56a57e970b6b6adf63201811ce45faee471cf3521c6b4ccecc67f3befc727b2e77189ac5 WHIRLPOOL fd848310465a7d2ec664acd60c14eae0be62ed77a58682d8248c6a233e746a944e7ad6852804d035bb74b0b717e78095e81075e29ed3793133f6e35e20aa1316
diff --git a/app-text/keepnote/files/keepnote-0.7.8-desktopfile.patch b/app-text/keepnote/files/keepnote-0.7.8-desktopfile.patch
new file mode 100644
index 000000000000..7c06aab2c91d
--- /dev/null
+++ b/app-text/keepnote/files/keepnote-0.7.8-desktopfile.patch
@@ -0,0 +1,30 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Tue Aug 14 07:08:05 UTC 2012
+Subject: desktop file
+
+respect fd.o desktop entry spec
+
+# desktop-file-validate keepnote.desktop
+keepnote.desktop: warning: key "Encoding" in group "Desktop Entry" is deprecated
+keepnote.desktop: warning: value "Note-taking Application" for key "Comment" in group "Desktop Entry" looks redundant with value "Note-taking Application" of key "GenericName"
+keepnote.desktop: warning: value "Program na spr?vu pozn?mok" for key "Comment[sk]" in group "Desktop Entry" looks redundant with value "Program na spr?vu pozn?mok" of key "GenericName[sk]"
+keepnote.desktop: error: value "Office" for string list key "Categories" in group "Desktop Entry" does not have a semicolon (';') as trailing character
+
+--- desktop/keepnote.desktop
++++ desktop/keepnote.desktop
+@@ -1,14 +1,11 @@
+ [Desktop Entry]
+-Encoding=UTF-8
+ Type=Application
+ Name=KeepNote
+ GenericName=Note-taking Application
+ GenericName[sk]=Program na správu poznámok
+-Comment=Note-taking Application
+-Comment[sk]=Program na správu poznámok
+ Icon=keepnote
+ Exec=keepnote %f
+-Categories=Office
++Categories=Office;
+ #MimeType=
+ Terminal=false
+ StartupNotify=false
diff --git a/app-text/keepnote/keepnote-0.7.9-r2.ebuild b/app-text/keepnote/keepnote-0.7.9-r2.ebuild
new file mode 100644
index 000000000000..b46534993af0
--- /dev/null
+++ b/app-text/keepnote/keepnote-0.7.9-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite,xml"
+
+inherit gnome2-utils distutils-r1
+
+DESCRIPTION="A note taking application"
+HOMEPAGE="http://keepnote.org/"
+SRC_URI="http://keepnote.org/download-test/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ x11-misc/xdg-utils"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.7.8-desktopfile.patch )
+DOCS=( CHANGES )
+
+python_test() {
+ "${PYTHON}" test/testing.py || die
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ einfo
+ elog "optional dependencies:"
+ elog " app-text/gtkspell:2 (spell checking)"
+ einfo
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-text/keepnote/metadata.xml b/app-text/keepnote/metadata.xml
new file mode 100644
index 000000000000..87c0dfde9c52
--- /dev/null
+++ b/app-text/keepnote/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>rasmus@alum.mit.edu</email>
+ <name>Matt Rasmussen</name>
+ </maintainer>
+ <doc lang="en">http://keepnote.org/manual/</doc>
+ <bugs-to>https://code.google.com/p/keepnote/issues/list</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+ KeepNote is a note taking application . With KeepNote, you can
+ store your class notes, TODO lists, research notes, journal entries,
+ paper outlines, etc in a simple notebook hierarchy with rich-text
+ formatting, images, and more. Using full-text search, you can
+ retrieve any note for later reference.
+ </longdescription>
+</pkgmetadata>
+