summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/libxmlpatch/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/libxmlpatch/files')
-rw-r--r--app-text/libxmlpatch/files/libxmlpatch-0.3.3-gentoo.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-text/libxmlpatch/files/libxmlpatch-0.3.3-gentoo.patch b/app-text/libxmlpatch/files/libxmlpatch-0.3.3-gentoo.patch
new file mode 100644
index 000000000000..a18104fb12b5
--- /dev/null
+++ b/app-text/libxmlpatch/files/libxmlpatch-0.3.3-gentoo.patch
@@ -0,0 +1,56 @@
+Index: libxmlpatch-0.3.3/tests/check_diff.c
+===================================================================
+--- libxmlpatch-0.3.3.orig/tests/check_diff.c
++++ libxmlpatch-0.3.3/tests/check_diff.c
+@@ -259,7 +259,13 @@ static struct {
+ static void
+ add_test (TCase *tc, int i)
+ {
+- _tcase_add_test (tc, arr_tests[i].fn, arr_tests[i].name, 0, 0, 1);
++ _tcase_add_test (tc, arr_tests[i].fn, arr_tests[i].name,
++#if CHECK_MAJOR_VERSION > 0 || \
++ (CHECK_MAJOR_VERSION == 0 && CHECK_MINOR_VERSION > 9) || \
++ (CHECK_MAJOR_VERSION == 0 && CHECK_MINOR_VERSION == 9 && CHECK_MICRO_VERSION >= 7)
++ 0,
++#endif
++ 0, 0, 1);
+ }
+
+ static void
+Index: libxmlpatch-0.3.3/configure.in
+===================================================================
+--- libxmlpatch-0.3.3.orig/configure.in
++++ libxmlpatch-0.3.3/configure.in
+@@ -74,7 +74,13 @@ fi
+
+ PKG_CHECK_MODULES(DEPS_XML, libxml-2.0)
+ PKG_CHECK_MODULES(DEPS_GLIB, glib-2.0)
+-PKG_CHECK_MODULES([CHECK], [check >= 0.9.4])
++
++AC_ARG_WITH([check],
++ AS_HELP_STRING([--without-check], [Do not build tests based on check package @<:@default=auto@:>@]))
++AS_IF([test "x$with_check" != "xno"], [
++PKG_CHECK_MODULES([CHECK], [check >= 0.9.4], , [with_check=no])
++])
++AM_CONDITIONAL([TESTS], [test "x$with_check" != "xno"])
+
+ AC_SUBST(DEPS_XML_CFLAGS)
+ AC_SUBST(DEPS_XML_LIBS)
+Index: libxmlpatch-0.3.3/tests/Makefile.am
+===================================================================
+--- libxmlpatch-0.3.3.orig/tests/Makefile.am
++++ libxmlpatch-0.3.3/tests/Makefile.am
+@@ -1,10 +1,11 @@
++if TESTS
+ TESTS = test-diff
++check_PROGRAMS = test-diff
++endif
+
+-test_PROGRAMS = test-diff
+ test_diff_SOURCES = check_diff.c
+ test_diff_CFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/diff @CHECK_CFLAGS@ $(DEPS_XML_CFLAGS) $(DEPS_GLIB_CFLAGS)
+ test_diff_LDADD = @CHECK_LIBS@ $(top_builddir)/src/libxmlpatch.la $(top_builddir)/diff/libxmldiff.la $(DEPS_XML_LIBS) $(DEPS_GLIB_LIBS)
+-testdir = $(libdir)/tests/xml_diff
+
+ bin_PROGRAMS = xml_patch xml_diff
+