summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-23 13:58:27 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-23 14:36:19 +0200
commitdc300285e7d04a581db084f6747b8c5835caf3b8 (patch)
treea522e26aa3aacf043c6a102abcf5874ea574f63d /app-text/ocrad/ocrad-0.26.ebuild
parentsys-libs/uclibc-ng: version bump to 1.0.24 (diff)
downloadgentoo-dc300285e7d04a581db084f6747b8c5835caf3b8.tar.gz
gentoo-dc300285e7d04a581db084f6747b8c5835caf3b8.tar.bz2
gentoo-dc300285e7d04a581db084f6747b8c5835caf3b8.zip
app-text/ocrad: bump to 0.26
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-text/ocrad/ocrad-0.26.ebuild')
-rw-r--r--app-text/ocrad/ocrad-0.26.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/ocrad/ocrad-0.26.ebuild b/app-text/ocrad/ocrad-0.26.ebuild
new file mode 100644
index 000000000000..1dc0d0045405
--- /dev/null
+++ b/app-text/ocrad/ocrad-0.26.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit unpacker toolchain-funcs
+
+DESCRIPTION="GNU Ocrad is an OCR (Optical Character Recognition) program"
+HOMEPAGE="https://www.gnu.org/software/ocrad/ocrad.html"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="$(unpacker_src_uri_depends)"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_configure() {
+ # ./configure is not based on autotools
+ ./configure \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ --prefix=/usr
+}
+
+src_install() {
+ default
+ doman doc/${PN}.1
+ doinfo doc/${PN}.info
+}