summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-26 07:04:41 +0100
committerSam James <sam@gentoo.org>2022-07-26 07:22:05 +0100
commit880bd1a2cac26d7a969819e2f3b7180276c53c73 (patch)
tree12347a4f70c42f13f83ff45640111f34ac6e011f /app-text/unpaper
parentmedia-gfx/imagemagick: add 7.1.0.44 (diff)
downloadgentoo-880bd1a2cac26d7a969819e2f3b7180276c53c73.tar.gz
gentoo-880bd1a2cac26d7a969819e2f3b7180276c53c73.tar.bz2
gentoo-880bd1a2cac26d7a969819e2f3b7180276c53c73.zip
app-text/unpaper: add 7.0.0
Closes: https://bugs.gentoo.org/831607 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/unpaper')
-rw-r--r--app-text/unpaper/Manifest1
-rw-r--r--app-text/unpaper/unpaper-7.0.0.ebuild31
-rw-r--r--app-text/unpaper/unpaper-9999.ebuild29
3 files changed, 45 insertions, 16 deletions
diff --git a/app-text/unpaper/Manifest b/app-text/unpaper/Manifest
index 17c2bd98c4ee..4f3ac2e27f19 100644
--- a/app-text/unpaper/Manifest
+++ b/app-text/unpaper/Manifest
@@ -1 +1,2 @@
DIST unpaper-6.1.tar.xz 2655724 BLAKE2B df16261d37d5d493aa640cd940b63f55e90ba091e6028dc11dd0c685ec880a7be202d4056756ef0fa54b48b89f1845b9cf23aceeb87945a1b6a25eec4b7c0915 SHA512 afef705985d3c265672c9e42130acc34befc080c361f3169e299b5110c662d0b9845a9d0ca4fc3aad468f49967ded36fb60ffed296373569dd7337c3cb81e79c
+DIST unpaper-7.0.0.tar.xz 4430572 BLAKE2B 4ab27df9f859b9238ce866c65b7e2d4214a96883be35259494db0115594804a8bc76dc0c60324f147d76865c2cedaaffa70f7a2785fdad2e5c103ca66fa49ea3 SHA512 58da969e773bf16ffee98b96f903ac5347f66d9a93c63bdb9131f5d45f4d7973c09f364ac2f27f8cb61f75de0421c6b01aa248fa9619fbdbde30fcebc76aa484
diff --git a/app-text/unpaper/unpaper-7.0.0.ebuild b/app-text/unpaper/unpaper-7.0.0.ebuild
new file mode 100644
index 000000000000..a26b83763386
--- /dev/null
+++ b/app-text/unpaper/unpaper-7.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Flameeyes/unpaper.git"
+ inherit git-r3
+else
+ SRC_URI="https://www.flameeyes.eu/files/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DESCRIPTION="Post-processor for scanned and photocopied book pages"
+HOMEPAGE="https://www.flameeyes.eu/projects/unpaper"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=media-video/ffmpeg-2:0=[encode]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xsl-ns-stylesheets
+ dev-libs/libxslt
+ dev-python/sphinx
+ test? ( dev-python/pytest )
+"
diff --git a/app-text/unpaper/unpaper-9999.ebuild b/app-text/unpaper/unpaper-9999.ebuild
index cb59b6c27de1..a26b83763386 100644
--- a/app-text/unpaper/unpaper-9999.ebuild
+++ b/app-text/unpaper/unpaper-9999.ebuild
@@ -1,14 +1,16 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
+inherit meson
if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/Flameeyes/unpaper.git"
- inherit git-r3 autotools
+ inherit git-r3
else
SRC_URI="https://www.flameeyes.eu/files/${P}.tar.xz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~x86"
fi
DESCRIPTION="Post-processor for scanned and photocopied book pages"
@@ -17,18 +19,13 @@ HOMEPAGE="https://www.flameeyes.eu/projects/unpaper"
LICENSE="GPL-2"
SLOT="0"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND=">=media-video/ffmpeg-2:0=[encode]"
-DEPEND="dev-libs/libxslt
+DEPEND="${RDEPEND}"
+BDEPEND="
app-text/docbook-xsl-ns-stylesheets
- virtual/pkgconfig
- ${RDEPEND}"
-
-# gcc can generate slightly different code that leads to slightly different
-# images. Wait until we get a better testsuite.
-RESTRICT="test"
-
-src_prepare() {
- default
- [[ ${PV} == *9999 ]] && eautoreconf
-}
+ dev-libs/libxslt
+ dev-python/sphinx
+ test? ( dev-python/pytest )
+"