summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMason Rocha <turret@turret.cyou>2023-08-28 17:37:11 -0500
committerSam James <sam@gentoo.org>2023-08-29 02:20:19 +0100
commit60fc99439f84122876d97f09357a15ed4aa92538 (patch)
tree7f9e4c43f77f053d315767fb14d12eb8cf0ccc56 /app-text/zathura
parentapp-text/zathura: add myself as new maintainer (diff)
downloadgentoo-60fc99439f84122876d97f09357a15ed4aa92538.tar.gz
gentoo-60fc99439f84122876d97f09357a15ed4aa92538.tar.bz2
gentoo-60fc99439f84122876d97f09357a15ed4aa92538.zip
app-text/zathura: EAPI bump, use live template, fix test
Signed-off-by: Mason Rocha <turret@turret.cyou> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/zathura')
-rw-r--r--app-text/zathura/zathura-0.5.2-r5.ebuild (renamed from app-text/zathura/zathura-0.5.2-r4.ebuild)36
-rw-r--r--app-text/zathura/zathura-9999.ebuild38
2 files changed, 45 insertions, 29 deletions
diff --git a/app-text/zathura/zathura-0.5.2-r4.ebuild b/app-text/zathura/zathura-0.5.2-r5.ebuild
index 249ff0cbb654..1ad4fe4776d4 100644
--- a/app-text/zathura/zathura-0.5.2-r4.ebuild
+++ b/app-text/zathura/zathura-0.5.2-r5.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson virtualx xdg
@@ -15,9 +15,9 @@ if [[ ${PV} == *9999 ]]; then
else
SRC_URI="
https://github.com/pwmt/zathura/archive/${PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~slashbeast/distfiles/${PN}/${P}-manpages.tar.xz
+ https://cdn.turret.cyou/354c6d33bfd3bbc67c0047af1328498978eef352/${P}-manpages.tar.xz
"
- KEYWORDS="amd64 arm ~riscv x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="ZLIB"
@@ -26,22 +26,26 @@ IUSE="seccomp sqlite synctex test"
RESTRICT="!test? ( test )"
-DEPEND=">=dev-libs/girara-0.3.7
+DEPEND="
+ >=dev-libs/girara-0.3.7
>=dev-libs/glib-2.50:2
+ sys-apps/file
>=sys-devel/gettext-0.19.8
x11-libs/cairo
>=x11-libs/gtk+-3.22:3
- sys-apps/file
seccomp? ( sys-libs/libseccomp )
sqlite? ( >=dev-db/sqlite-3.5.9:3 )
- synctex? ( app-text/texlive-core )"
-
+ synctex? ( app-text/texlive-core )
+"
RDEPEND="${DEPEND}"
-
BDEPEND="
- test? ( dev-libs/appstream-glib
- dev-libs/check )
- virtual/pkgconfig"
+ test? (
+ dev-libs/appstream-glib
+ dev-libs/check
+ x11-base/xorg-server[xvfb]
+ )
+ virtual/pkgconfig
+"
PATCHES=(
"${FILESDIR}"/zathura-disable-seccomp-tests.patch
@@ -58,11 +62,11 @@ src_configure() {
meson_src_configure
}
-src_install() {
- meson_src_install
- doman "${WORKDIR}"/man/zathura*
-}
-
src_test() {
virtx meson_src_test
}
+
+src_install() {
+ meson_src_install
+ [[ ${PV} != *9999 ]] && doman "${WORKDIR}"/man/zathura*
+}
diff --git a/app-text/zathura/zathura-9999.ebuild b/app-text/zathura/zathura-9999.ebuild
index 871f9948e8f7..1ad4fe4776d4 100644
--- a/app-text/zathura/zathura-9999.ebuild
+++ b/app-text/zathura/zathura-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson virtualx xdg
@@ -13,7 +13,10 @@ if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
EGIT_BRANCH="develop"
else
- SRC_URI="https://github.com/pwmt/zathura/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="
+ https://github.com/pwmt/zathura/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://cdn.turret.cyou/354c6d33bfd3bbc67c0047af1328498978eef352/${P}-manpages.tar.xz
+ "
KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
fi
@@ -23,22 +26,26 @@ IUSE="seccomp sqlite synctex test"
RESTRICT="!test? ( test )"
-DEPEND=">=dev-libs/girara-0.3.7
+DEPEND="
+ >=dev-libs/girara-0.3.7
>=dev-libs/glib-2.50:2
+ sys-apps/file
>=sys-devel/gettext-0.19.8
x11-libs/cairo
>=x11-libs/gtk+-3.22:3
- sys-apps/file
seccomp? ( sys-libs/libseccomp )
sqlite? ( >=dev-db/sqlite-3.5.9:3 )
- synctex? ( app-text/texlive-core )"
-
+ synctex? ( app-text/texlive-core )
+"
RDEPEND="${DEPEND}"
-
-BDEPEND="dev-python/sphinx
- test? ( dev-libs/appstream-glib
- dev-libs/check )
- virtual/pkgconfig"
+BDEPEND="
+ test? (
+ dev-libs/appstream-glib
+ dev-libs/check
+ x11-base/xorg-server[xvfb]
+ )
+ virtual/pkgconfig
+"
PATCHES=(
"${FILESDIR}"/zathura-disable-seccomp-tests.patch
@@ -47,7 +54,7 @@ PATCHES=(
src_configure() {
local emesonargs=(
-Dconvert-icon=disabled
- -Dmanpages=enabled
+ -Dmanpages=disabled
-Dseccomp=$(usex seccomp enabled disabled)
-Dsqlite=$(usex sqlite enabled disabled)
-Dsynctex=$(usex synctex enabled disabled)
@@ -58,3 +65,8 @@ src_configure() {
src_test() {
virtx meson_src_test
}
+
+src_install() {
+ meson_src_install
+ [[ ${PV} != *9999 ]] && doman "${WORKDIR}"/man/zathura*
+}