summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-09-16 11:28:46 +0100
committerMarek Szuba <marecki@gentoo.org>2022-09-16 11:30:39 +0100
commitfcd2b1fd112eadb8125a624fa30e3d9b4e2ec2db (patch)
tree52652623d6ce5df3d1f564a4ac29bf0817557c2a /app-text
parentdev-libs/nspr: Stabilize 4.34.1 hppa, #869260 (diff)
downloadgentoo-fcd2b1fd112eadb8125a624fa30e3d9b4e2ec2db.tar.gz
gentoo-fcd2b1fd112eadb8125a624fa30e3d9b4e2ec2db.tar.bz2
gentoo-fcd2b1fd112eadb8125a624fa30e3d9b4e2ec2db.zip
app-text/bibletime: add option to install offline documentation
All languages for now, with a discrepancy in language support between the howto and the handbook making these selectable will need some effort + the generation overhead is fairly minimal. Closes: https://bugs.gentoo.org/869875 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/bibletime/bibletime-3.0.3-r4.ebuild (renamed from app-text/bibletime/bibletime-3.0.3-r3.ebuild)16
1 files changed, 13 insertions, 3 deletions
diff --git a/app-text/bibletime/bibletime-3.0.3-r3.ebuild b/app-text/bibletime/bibletime-3.0.3-r4.ebuild
index 7c4cc4b09136..955de2fe3119 100644
--- a/app-text/bibletime/bibletime-3.0.3-r3.ebuild
+++ b/app-text/bibletime/bibletime-3.0.3-r4.ebuild
@@ -12,6 +12,7 @@ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="doc"
RDEPEND=">=app-text/sword-1.8.1[curl,icu]
dev-cpp/clucene
@@ -26,7 +27,13 @@ RDEPEND=">=app-text/sword-1.8.1[curl,icu]
DEPEND="${RDEPEND}
dev-libs/boost
dev-qt/qttest:5"
-BDEPEND="dev-qt/linguist-tools:5"
+BDEPEND="dev-qt/linguist-tools:5
+ doc? (
+ app-text/docbook-xml-dtd
+ app-text/docbook-xsl-stylesheets
+ app-text/po4a
+ dev-libs/libxslt
+ )"
PATCHES=(
"${FILESDIR}"/${PN}-3.0.3-no_indirect_deps.patch
@@ -41,11 +48,14 @@ src_prepare() {
-i cmake/platforms/linux/bibletime.desktop.cmake || die "fixing .desktop file failed"
}
+# TODO: FOO_HTML_LANGUAGES. Current lists for "all languages":
+# handbook: ar br cs de en es fi fr hu it ko lt nl pt_BR ru th uk
+# howto: ar bg br cs da de en es fi fr hu it ja ko lt nl pt_BR ru th uk
src_configure() {
local mycmakeargs=(
- -DBUILD_HANDBOOK_HTML=no
+ -DBUILD_HANDBOOK_HTML=$(usex doc)
-DBUILD_HANDBOOK_PDF=no
- -DBUILD_HOWTO_HTML=no
+ -DBUILD_HOWTO_HTML=$(usex doc)
-DBUILD_HOWTO_PDF=no
)
cmake_src_configure