summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/command-t
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/command-t')
-rw-r--r--app-vim/command-t/Manifest3
-rw-r--r--app-vim/command-t/command-t-1.11.3.ebuild40
-rw-r--r--app-vim/command-t/command-t-1.11.4.ebuild40
-rw-r--r--app-vim/command-t/command-t-1.9.1.ebuild40
-rw-r--r--app-vim/command-t/metadata.xml5
5 files changed, 128 insertions, 0 deletions
diff --git a/app-vim/command-t/Manifest b/app-vim/command-t/Manifest
new file mode 100644
index 000000000000..07147fd2fa1c
--- /dev/null
+++ b/app-vim/command-t/Manifest
@@ -0,0 +1,3 @@
+DIST command-t-1.11.3.tar.bz2 42697 SHA256 f999e6c2e697e854f687f1795824efec552a8175b238e4136a3b592e760b1049 SHA512 46207a70c162a76f7ebffec4e4fbcf7e15e8ebdf58f177e65b2cb1ff01954b84fb04900c354c7d3cb37aa69cab223407564b19ac83b3fbbc2f862d26fe969d9f WHIRLPOOL eeb1ef004dae3601baec463801fadf77d65f7e78bb2c6ced88e02237cec1670ea3ef32b3af7faf5906403ae390bb2b919e1b11732c01bb00815941252895c887
+DIST command-t-1.11.4.tar.bz2 43107 SHA256 8b3b9b70397621d23e74c817f5807319f769253cf82de471913294a8e702ab62 SHA512 d3e35e6c0c144338c3966c6b57822193080ed1ef181ccd2d6ecd480dbe023788d33d82518a8461a7525ee3d4ca9fc643beb250e18aa7cfd691c6bc6aad4a6644 WHIRLPOOL e92fe0ae2b8ec1e5e029be21fd02142b241321e3a15fed5e6e522f64e55daf0d3eb348eedfd0bdad712d130ced10b3116328428379f2ae92f60304b2379c676c
+DIST command-t-1.9.1.tar.bz2 40258 SHA256 23a1fa7cd40538af915407d9db0c7c6729b59866284bd1ace4fb5ae2c6024701 SHA512 29feb689e5485e9686ef71b667786bfd8d1da5480ca5d8fab43a4a52eac34d78afe00c02d18517418102d7cc6b95c5cb7aec66579e774e40dd122fd6458ab284 WHIRLPOOL bc19c4feaaddaa3b403f454434020ad94ed012963fdccda92cdfd527ede9230c8aabdf87cfe726d9e59c966a0880b9b180ce0ddc8ddc7714ce7c6aac0ac67e36
diff --git a/app-vim/command-t/command-t-1.11.3.ebuild b/app-vim/command-t/command-t-1.11.3.ebuild
new file mode 100644
index 000000000000..e8dd4db5e09e
--- /dev/null
+++ b/app-vim/command-t/command-t-1.11.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+inherit vim-plugin ruby-ng
+
+DESCRIPTION="vim plugin: fast file navigation for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3025
+ https://wincent.com/products/command-t"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="|| ( app-editors/vim[ruby] app-editors/gvim[ruby] )"
+
+each_ruby_configure() {
+ cd ruby/${PN}
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ cd ruby/${PN}
+ emake V=1
+ rm *.o *.c *.h *.log extconf.rb depend Makefile || die
+}
+
+each_ruby_install() {
+ local sitelibdir=$(ruby_rbconfig_value "sitelibdir")
+ insinto ${sitelibdir}/${PN}
+ doins -r ruby/${PN}/*
+}
+
+all_ruby_install() {
+ rm -r ruby || die
+ vim-plugin_src_install
+}
diff --git a/app-vim/command-t/command-t-1.11.4.ebuild b/app-vim/command-t/command-t-1.11.4.ebuild
new file mode 100644
index 000000000000..e8dd4db5e09e
--- /dev/null
+++ b/app-vim/command-t/command-t-1.11.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+inherit vim-plugin ruby-ng
+
+DESCRIPTION="vim plugin: fast file navigation for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3025
+ https://wincent.com/products/command-t"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="|| ( app-editors/vim[ruby] app-editors/gvim[ruby] )"
+
+each_ruby_configure() {
+ cd ruby/${PN}
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ cd ruby/${PN}
+ emake V=1
+ rm *.o *.c *.h *.log extconf.rb depend Makefile || die
+}
+
+each_ruby_install() {
+ local sitelibdir=$(ruby_rbconfig_value "sitelibdir")
+ insinto ${sitelibdir}/${PN}
+ doins -r ruby/${PN}/*
+}
+
+all_ruby_install() {
+ rm -r ruby || die
+ vim-plugin_src_install
+}
diff --git a/app-vim/command-t/command-t-1.9.1.ebuild b/app-vim/command-t/command-t-1.9.1.ebuild
new file mode 100644
index 000000000000..e8dd4db5e09e
--- /dev/null
+++ b/app-vim/command-t/command-t-1.9.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+inherit vim-plugin ruby-ng
+
+DESCRIPTION="vim plugin: fast file navigation for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3025
+ https://wincent.com/products/command-t"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="|| ( app-editors/vim[ruby] app-editors/gvim[ruby] )"
+
+each_ruby_configure() {
+ cd ruby/${PN}
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ cd ruby/${PN}
+ emake V=1
+ rm *.o *.c *.h *.log extconf.rb depend Makefile || die
+}
+
+each_ruby_install() {
+ local sitelibdir=$(ruby_rbconfig_value "sitelibdir")
+ insinto ${sitelibdir}/${PN}
+ doins -r ruby/${PN}/*
+}
+
+all_ruby_install() {
+ rm -r ruby || die
+ vim-plugin_src_install
+}
diff --git a/app-vim/command-t/metadata.xml b/app-vim/command-t/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/command-t/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>