summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/repeat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/repeat')
-rw-r--r--app-vim/repeat/Manifest1
-rw-r--r--app-vim/repeat/metadata.xml8
-rw-r--r--app-vim/repeat/repeat-1.1.ebuild22
3 files changed, 31 insertions, 0 deletions
diff --git a/app-vim/repeat/Manifest b/app-vim/repeat/Manifest
new file mode 100644
index 000000000000..56c505a60691
--- /dev/null
+++ b/app-vim/repeat/Manifest
@@ -0,0 +1 @@
+DIST repeat-1.1.tar.gz 2621 SHA256 1e7f98140d126622352e85483ce33f41ab44ca64fd0fea7bc501d2ac5e643c98 SHA512 9df73c7049f38a93da5e6bd36dc0fe833ec23394540de1b6929159910ec9f18af2a76211af612bc8f3c92d9c7f2faacd72a65d7d593584689ac6a7068df60bf9 WHIRLPOOL 5a0c03aadab21f2da125d4fcac6eb6fee8941334ab3f6f839e4db9a5b4651533beafa520a7f6c08b27d82f90ad1e28195240fa379b2eeee4f22ae979da814388
diff --git a/app-vim/repeat/metadata.xml b/app-vim/repeat/metadata.xml
new file mode 100644
index 000000000000..df6613320687
--- /dev/null
+++ b/app-vim/repeat/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <upstream>
+ <remote-id type="github">tpope/vim-repeat</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/repeat/repeat-1.1.ebuild b/app-vim/repeat/repeat-1.1.ebuild
new file mode 100644
index 000000000000..f282d489d8d3
--- /dev/null
+++ b/app-vim/repeat/repeat-1.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+MY_PN="vim-repeat"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="vim plugin: use the repeat command \".\" with plugin maps"
+HOMEPAGE="https://github.com/tpope/vim-repeat/ http://www.vim.org/scripts/script.php?script_id=2136"
+SRC_URI="https://github.com/tpope/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="amd64 x86"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ rm *.markdown || die
+}