summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ada/booch_components/booch_components-20070420.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ada/booch_components/booch_components-20070420.ebuild')
-rw-r--r--dev-ada/booch_components/booch_components-20070420.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/dev-ada/booch_components/booch_components-20070420.ebuild b/dev-ada/booch_components/booch_components-20070420.ebuild
new file mode 100644
index 000000000000..4d668809228b
--- /dev/null
+++ b/dev-ada/booch_components/booch_components-20070420.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+IUSE="doc"
+
+inherit gnat
+
+My_PN="bc"
+S="${WORKDIR}/${My_PN}-${PV}"
+DESCRIPTION="Booch Components for Ada"
+SRC_URI="mirror://sourceforge/booch95/${My_PN}-${PV}.tgz
+ mirror://sourceforge/booch95/${My_PN}-html-${PV}.zip"
+
+HOMEPAGE="http://booch95.sourceforge.net/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+
+RDEPEND="virtual/ada"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+lib_compile() {
+ cd "${SL}"/GNAT
+ make
+}
+
+lib_install() {
+ mkdir -p "${DL}"/Debug
+ mv "${SL}"/GNAT/*-Release/lib/* "${DL}"
+ mv "${SL}"/GNAT/*-Debug/lib/* "${DL}"/Debug
+ chmod 0444 "${DL}"/*.ali "${DL}"/Debug/*.ali
+}
+
+src_install () {
+ dodir "${AdalibSpecsDir}/${PN}"
+ insinto "${AdalibSpecsDir}/${PN}"
+ doins *.ad?
+
+ #set up environment
+ echo "LDPATH=%DL%" > ${LibEnv}
+ echo "ADA_OBJECTS_PATH=%DL%" >> ${LibEnv}
+ echo "ADA_INCLUDE_PATH=${AdalibSpecsDir}/${PN}" >> ${LibEnv}
+
+ gnat_src_install
+
+ # Install documentation.
+ dodoc README
+ if use doc ; then
+ einfo "installing docs"
+ cd "${WORKDIR}"
+ dohtml *.html *.gif *.jpg
+ cp coldframe-hash.* x.ada "${D}"/usr/share/doc/${PF}/html
+
+ cd "${S}"
+ dodir /usr/share/doc/${PF}/demo
+ insinto /usr/share/doc/${PF}/demo
+ doins demo/*
+
+ dodir /usr/share/doc/${PF}/test
+ insinto /usr/share/doc/${PF}/test
+ doins test/*
+ fi
+}