summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2017-03-26 22:02:54 +0200
committerTupone Alfredo <tupone@gentoo.org>2017-03-26 22:02:54 +0200
commit14755823acb49bf2d36e0d3d5dfa4ee48ffc3a8c (patch)
treedb58af1128706e1d1e7cdd6d3bab4735989cf25b /dev-ada/xmlada/files
parentdev-php/phpunit: Mark ~hppa (bug #613766). (diff)
downloadgentoo-14755823acb49bf2d36e0d3d5dfa4ee48ffc3a8c.tar.gz
gentoo-14755823acb49bf2d36e0d3d5dfa4ee48ffc3a8c.tar.bz2
gentoo-14755823acb49bf2d36e0d3d5dfa4ee48ffc3a8c.zip
dev-ada/xmlada: Add dev-ada/xmlada
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ada/xmlada/files')
-rw-r--r--dev-ada/xmlada/files/xmlada-2016-gentoo.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ada/xmlada/files/xmlada-2016-gentoo.patch b/dev-ada/xmlada/files/xmlada-2016-gentoo.patch
new file mode 100644
index 000000000000..e167c1df1452
--- /dev/null
+++ b/dev-ada/xmlada/files/xmlada-2016-gentoo.patch
@@ -0,0 +1,38 @@
+--- xmlada-2016-src/Makefile.in.old 2016-12-04 21:58:57.251338692 +0100
++++ xmlada-2016-src/Makefile.in 2016-12-04 21:59:31.332755615 +0100
+@@ -7,7 +7,7 @@
+ PACKAGE_TARNAME=@PACKAGE_TARNAME@
+ VERSION=@PACKAGE_VERSION@
+ BUILDS_SHARED=@GNAT_BUILDS_SHARED@
+-prefix=@prefix@
++prefix=$(DESTDIR)@prefix@
+
+ # Set a default value (ignored if set in the environment)
+ PROCESSORS?=0
+@@ -49,13 +49,13 @@
+ endif
+
+ static:
+- ${GPRBUILD} -p -XLIBRARY_TYPE=static ${GPROPTS} xmlada.gpr
++ ${GPRBUILD} -p -XLIBRARY_TYPE=static ${GPROPTS} xmlada.gpr -cargs $(ADAFLAGS)
+
+ shared relocatable:
+- ${GPRBUILD} -p -XLIBRARY_TYPE=relocatable ${GPROPTS} xmlada.gpr
++ ${GPRBUILD} -p -XLIBRARY_TYPE=relocatable ${GPROPTS} xmlada.gpr -cargs $(ADAFLAGS)
+
+ static-pic:
+- ${GPRBUILD} -p -XLIBRARY_TYPE=static-pic ${GPROPTS} xmlada.gpr
++ ${GPRBUILD} -p -XLIBRARY_TYPE=static-pic ${GPROPTS} xmlada.gpr -cargs $(ADAFLAGS)
+
+ # Rebuild the tests (and not the XML/Ada code itself)
+ test: force
+--- xmlada-gpl-2016-src/shared.gpr.in.old 2017-03-26 21:48:46.613541125 +0200
++++ xmlada-gpl-2016-src/shared.gpr.in 2017-03-26 21:49:32.713754025 +0200
+@@ -76,6 +76,7 @@
+ when "profile" =>
+ for Switches ("Ada") use warnings & ("-g", "-pg");
+ end case;
++ for Driver ("Ada") use External ("ADA", "gcc");
+ end compiler;
+
+ package binder is