summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-13 21:17:08 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-14 20:23:13 +0100
commitfef0597c769e788a0abd9c74901dc5e10df04729 (patch)
tree36b719ba67c1edd6b65c77debb7bb29bcc284697 /dev-build
parentMove {dev-util → dev-build}/cmake-fedora (diff)
downloadgentoo-fef0597c769e788a0abd9c74901dc5e10df04729.tar.gz
gentoo-fef0597c769e788a0abd9c74901dc5e10df04729.tar.bz2
gentoo-fef0597c769e788a0abd9c74901dc5e10df04729.zip
Move {dev-util → dev-build}/ignition-cmake
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/ignition-cmake/Manifest1
-rw-r--r--dev-build/ignition-cmake/files/protobuf.patch54
-rw-r--r--dev-build/ignition-cmake/ignition-cmake-2.17.0.ebuild24
-rw-r--r--dev-build/ignition-cmake/metadata.xml12
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-build/ignition-cmake/Manifest b/dev-build/ignition-cmake/Manifest
new file mode 100644
index 000000000000..11a01f3e421a
--- /dev/null
+++ b/dev-build/ignition-cmake/Manifest
@@ -0,0 +1 @@
+DIST ignition-cmake2-2.17.0.tar.bz2 212353 BLAKE2B 4945559d35cea859383fc510fd2b78cbbd3127ef58c94fa239ecad3643725b7e003a9a18ddb25deec42938196adaf0a4f3466b602cf35dd1fe58f02c5a0ede91 SHA512 bb7263531c772474780fab990dafaa9697b1ce7d9113053bc7af3b2ae6cf292a46c6b37452e5bf720ef34ed3a9732503106d5e55b5ae813bed65618ae4ee69dc
diff --git a/dev-build/ignition-cmake/files/protobuf.patch b/dev-build/ignition-cmake/files/protobuf.patch
new file mode 100644
index 000000000000..1bb2fe6480bb
--- /dev/null
+++ b/dev-build/ignition-cmake/files/protobuf.patch
@@ -0,0 +1,54 @@
+Index: ignition-cmake-2.17.0/cmake/FindIgnProtobuf.cmake
+===================================================================
+--- ignition-cmake-2.17.0.orig/cmake/FindIgnProtobuf.cmake
++++ ignition-cmake-2.17.0/cmake/FindIgnProtobuf.cmake
+@@ -26,12 +26,12 @@
+ include(IgnPkgConfig)
+ ign_pkg_config_entry(IgnProtobuf "protobuf >= ${IgnProtobuf_FIND_VERSION}")
+
+-find_package(Protobuf ${IgnProtobuf_FIND_VERSION} QUIET CONFIG)
++find_package(protobuf ${IgnProtobuf_FIND_VERSION} QUIET CONFIG)
+
+-if(NOT ${Protobuf_FOUND})
++if(NOT ${protobuf_FOUND})
+ # If a config-file was not found, then fall back on the system-installed
+ # find-module that comes with CMake.
+- find_package(Protobuf ${IgnProtobuf_FIND_VERSION})
++ find_package(protobuf ${IgnProtobuf_FIND_VERSION})
+ endif()
+
+ set(IgnProtobuf_missing_components "")
+@@ -49,21 +49,21 @@ foreach(component ${IgnProtobuf_FIND_COM
+
+ if((${component} STREQUAL "libprotobuf") OR (${component} STREQUAL "all"))
+ if((NOT PROTOBUF_LIBRARY) AND (NOT TARGET protobuf::libprotobuf))
+- set(Protobuf_FOUND false)
++ set(protobuf_FOUND false)
+ ign_string_append(IgnProtobuf_missing_components "libprotobuf" DELIM " ")
+ endif()
+ endif()
+
+ if((${component} STREQUAL "libprotoc") OR (${component} STREQUAL "all"))
+ if((NOT PROTOBUF_PROTOC_LIBRARY) AND (NOT TARGET protobuf::libprotoc))
+- set(Protobuf_FOUND false)
++ set(protobuf_FOUND false)
+ ign_string_append(IgnProtobuf_missing_components "libprotoc" DELIM " ")
+ endif()
+ endif()
+
+ if((${component} STREQUAL "protoc") OR (${component} STREQUAL "all"))
+ if((NOT PROTOBUF_PROTOC_EXECUTABLE) AND (NOT TARGET protobuf::protoc))
+- set(Protobuf_FOUND false)
++ set(protobuf_FOUND false)
+ ign_string_append(IgnProtobuf_missing_components "protoc" DELIM " ")
+ endif()
+ endif()
+@@ -74,7 +74,7 @@ if(IgnProtobuf_missing_components AND NO
+ message(STATUS "Missing required protobuf components: ${IgnProtobuf_missing_components}")
+ endif()
+
+-if(${Protobuf_FOUND})
++if(${protobuf_FOUND})
+ # If we have found Protobuf, then set the IgnProtobuf_FOUND flag to true so
+ # that ign_find_package(~) knows that we were successful.
+ set(IgnProtobuf_FOUND true)
diff --git a/dev-build/ignition-cmake/ignition-cmake-2.17.0.ebuild b/dev-build/ignition-cmake/ignition-cmake-2.17.0.ebuild
new file mode 100644
index 000000000000..31bbb9701296
--- /dev/null
+++ b/dev-build/ignition-cmake/ignition-cmake-2.17.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="CMake modules to be used by the Ignition projects"
+HOMEPAGE="https://github.com/ignitionrobotics/ign-cmake"
+SRC_URI="https://osrf-distributions.s3.amazonaws.com/ign-cmake/releases/${PN}2-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+PATCHES=( "${FILESDIR}/protobuf.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ "-DBUILD_TESTING=$(usex test)"
+ )
+ cmake_src_configure
+}
diff --git a/dev-build/ignition-cmake/metadata.xml b/dev-build/ignition-cmake/metadata.xml
new file mode 100644
index 000000000000..2e5e0cfa84ea
--- /dev/null
+++ b/dev-build/ignition-cmake/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="bitbucket">ignitionrobotics/ign-cmake</remote-id>
+ <remote-id type="github">ignitionrobotics/ign-cmake</remote-id>
+ </upstream>
+</pkgmetadata>