summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-06-30 22:57:04 +0200
committerDavid Seifert <soap@gentoo.org>2019-06-30 22:57:04 +0200
commiteb7624865dabb5f1566798cdd18ba1f53fc3b603 (patch)
treedfee49e39c423e164ca85e95e2da63efe1034fc3 /dev-cpp/catch/catch-2.9.1.ebuild
parentsys-apps/nix: drop old (diff)
downloadgentoo-eb7624865dabb5f1566798cdd18ba1f53fc3b603.tar.gz
gentoo-eb7624865dabb5f1566798cdd18ba1f53fc3b603.tar.bz2
gentoo-eb7624865dabb5f1566798cdd18ba1f53fc3b603.zip
dev-cpp/catch: Version bump to 2.9.1
Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp/catch/catch-2.9.1.ebuild')
-rw-r--r--dev-cpp/catch/catch-2.9.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-cpp/catch/catch-2.9.1.ebuild b/dev-cpp/catch/catch-2.9.1.ebuild
new file mode 100644
index 000000000000..1a7d1ed8fba5
--- /dev/null
+++ b/dev-cpp/catch/catch-2.9.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit cmake-utils python-any-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/catchorg/Catch2.git"
+else
+ MY_P=${PN^}2-${PV}
+ SRC_URI="https://github.com/catchorg/Catch2/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+
+ S=${WORKDIR}/${MY_P}
+fi
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/catchorg/Catch2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCATCH_ENABLE_WERROR=OFF
+ -DBUILD_TESTING=$(usex test)
+ )
+ use test &&
+ mycmakeargs+=(-DPYTHON_EXECUTABLE="${PYTHON}")
+
+ cmake-utils_src_configure
+}