summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-04 04:33:36 +0000
committerSam James <sam@gentoo.org>2021-12-04 04:33:36 +0000
commit9fa634baf2ea8aa9ea672b31a260d6f7b07eb880 (patch)
tree343afc41b9bc5e085442cb8835c1c758d876ef23 /dev-cpp/elfio/elfio-3.9.ebuild
parentdev-util/libtree: initial import (diff)
downloadgentoo-9fa634baf2ea8aa9ea672b31a260d6f7b07eb880.tar.gz
gentoo-9fa634baf2ea8aa9ea672b31a260d6f7b07eb880.tar.bz2
gentoo-9fa634baf2ea8aa9ea672b31a260d6f7b07eb880.zip
dev-cpp/elfio: initial import
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/elfio/elfio-3.9.ebuild')
-rw-r--r--dev-cpp/elfio/elfio-3.9.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-cpp/elfio/elfio-3.9.ebuild b/dev-cpp/elfio/elfio-3.9.ebuild
new file mode 100644
index 000000000000..048dd0370aad
--- /dev/null
+++ b/dev-cpp/elfio/elfio-3.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="ELF reader/producer header-only C++ library"
+HOMEPAGE="https://github.com/serge1/ELFIO"
+SRC_URI="https://github.com/serge1/${PN}/archive/Release_${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN^^}-Release_${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-libs/boost )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DELFIO_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}