summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-cpp/tree
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-cpp/tree')
-rw-r--r--dev-cpp/tree/Manifest2
-rw-r--r--dev-cpp/tree/files/tree-2.62-test.patch17
-rw-r--r--dev-cpp/tree/files/tree-2.65-gcc46.patch15
-rw-r--r--dev-cpp/tree/metadata.xml12
-rw-r--r--dev-cpp/tree/tree-2.65-r1.ebuild42
-rw-r--r--dev-cpp/tree/tree-2.81.ebuild42
6 files changed, 130 insertions, 0 deletions
diff --git a/dev-cpp/tree/Manifest b/dev-cpp/tree/Manifest
new file mode 100644
index 000000000000..737725b3c0c8
--- /dev/null
+++ b/dev-cpp/tree/Manifest
@@ -0,0 +1,2 @@
+DIST tree-2.65.tar.gz 197695 SHA256 0198a86a2f9a72cbf6a46f0d7f25957c4cc0a62d3861f7999600bac94a642ce9 SHA512 59e8a7052c36082d8dfe848c88fbbc68d2d88ad50426559b218de850bd8953fd7a5142d028785b5c080d4ac67e1c6ff517ad6342365d021b29d4bfa259b9a552 WHIRLPOOL 2b16116b14677df0f6b6206d2ad9ed2b86932c7427ed5d29147dd15ee4182af03258b56108099309396aa1433d44fc0131149f83d00edcabfd46968e48ba6ad6
+DIST tree-2.81.tar.gz 1167128 SHA256 f1098afa236683a7292cb634e35d5f3111a587a68a063c6c5cf9dffac4e42d2b SHA512 85e910fdb19ffd03ae79302a95ebffdb44725fd9f291a61d6912f743b54fe9b3d1c863e00c7e75d238f428946809e42c7ae6379b1051688fb06ee6c6d761d294 WHIRLPOOL 0779c196a8c4aaec02ea8cce570837d39042109f493c4a058929be860f6007d4f0aa94069ffcc8a8e5e100c8c63c97cd2f0e73551c904979b8876eff2b716b1e
diff --git a/dev-cpp/tree/files/tree-2.62-test.patch b/dev-cpp/tree/files/tree-2.62-test.patch
new file mode 100644
index 000000000000..f7022426698b
--- /dev/null
+++ b/dev-cpp/tree/files/tree-2.62-test.patch
@@ -0,0 +1,17 @@
+--- test_tree.output 2008-08-28 11:16:11.000000000 +0100
++++ test_tree.output.new 2009-04-15 19:06:53.174832287 +0100
+@@ -1,3 +1,8 @@
++-----
++hi
++ 1
++ 0
++-----
+ empty tree to begin with:
+ 0
+ 'more text' is sibling 2 in its sibling range
+@@ -309,3 +314,5 @@
+ D
+ I
+ -----
++G
++H
diff --git a/dev-cpp/tree/files/tree-2.65-gcc46.patch b/dev-cpp/tree/files/tree-2.65-gcc46.patch
new file mode 100644
index 000000000000..d75b516112ba
--- /dev/null
+++ b/dev-cpp/tree/files/tree-2.65-gcc46.patch
@@ -0,0 +1,15 @@
+ tree.hh | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/tree.hh b/tree.hh
+index 1429da3..d780be3 100644
+--- a/tree.hh
++++ b/tree.hh
+@@ -71,6 +71,7 @@
+ #include <set>
+ #include <queue>
+ #include <algorithm>
++#include <cstddef>
+
+ // HP-style construct/destroy have gone from the standard,
+ // so here is a copy.
diff --git a/dev-cpp/tree/metadata.xml b/dev-cpp/tree/metadata.xml
new file mode 100644
index 000000000000..457a56288ad9
--- /dev/null
+++ b/dev-cpp/tree/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ The tree.hh library for C++ provides an STL-like container class for
+ n-ary trees, templated over the data stored at the nodes. Various
+ types of iterators are provided (post-order, pre-order, and
+ others). Where possible the access methods are compatible with the
+ STL or alternative algorithms are available.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-cpp/tree/tree-2.65-r1.ebuild b/dev-cpp/tree/tree-2.65-r1.ebuild
new file mode 100644
index 000000000000..f284c4d7cddf
--- /dev/null
+++ b/dev-cpp/tree/tree-2.65-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An STL-like tree class"
+HOMEPAGE="http://www.aei.mpg.de/~peekas/tree/"
+SRC_URI="http://www.aei.mpg.de/~peekas/tree/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # test was buggy, reported upstream
+ epatch \
+ "${FILESDIR}"/${PN}-2.62-test.patch \
+ "${FILESDIR}"/${P}-gcc46.patch
+}
+
+src_test() {
+ $(tc-getCXX) ${CXXFLAGS} test_tree.cc -o test_tree \
+ || die "compile test failed"
+ ./test_tree > mytest.output || die "running test failed"
+ diff -Nu test_tree.output mytest.output || die "test dist failed"
+}
+
+src_install() {
+ insinto /usr/include
+ doins tree.hh tree_util.hh || die
+ insinto /usr/share/doc/${PF}
+ doins tree_example.cc || die
+ if use doc; then
+ doins tree.pdf || die
+ fi
+}
diff --git a/dev-cpp/tree/tree-2.81.ebuild b/dev-cpp/tree/tree-2.81.ebuild
new file mode 100644
index 000000000000..cbfe8e2fbbdb
--- /dev/null
+++ b/dev-cpp/tree/tree-2.81.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An STL-like tree class"
+HOMEPAGE="http://www.aei.mpg.de/~peekas/tree/"
+SRC_URI="http://www.aei.mpg.de/~peekas/tree/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+S="${S}"/src
+
+src_prepare() {
+ rm Makefile || die
+ epatch "${FILESDIR}"/${PN}-2.62-test.patch
+}
+
+src_test() {
+ local test
+ test="$(tc-getCXX) ${CXXFLAGS} ${LDAFLAGS} test_tree.cc -o test_tree"
+
+ echo ${test}
+ eval ${test} || die "compile test failed"
+ ./test_tree > mytest.output || die "running test failed"
+ diff -Nu test_tree.output mytest.output || die "test dist failed"
+}
+
+src_install() {
+ insinto /usr/include
+ doins tree.hh tree_util.hh
+ dodoc tree_example.cc
+ if use doc; then
+ dohtml "${S}"/../doc/*
+ fi
+}