summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2024-05-21 13:51:27 -0500
committerMatthias Maier <tamiko@gentoo.org>2024-05-21 13:52:32 -0500
commit1c881dc5e0321e825eab9cbe132397e267c6e831 (patch)
tree2df8451b5c43ab552b6dfb960ed595b1f71007e7 /dev-cpp
parentdev-libs/pfs: drop a failing test (diff)
downloadgentoo-1c881dc5e0321e825eab9cbe132397e267c6e831.tar.gz
gentoo-1c881dc5e0321e825eab9cbe132397e267c6e831.tar.bz2
gentoo-1c881dc5e0321e825eab9cbe132397e267c6e831.zip
dev-cpp/taskflow: add 3.7.0
100% tests passed, 0 tests failed out of 2159 Total Test time (real) = 16.46 sec * Tests succeeded. >>> Completed testing dev-cpp/taskflow-3.7.0 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/taskflow/Manifest1
-rw-r--r--dev-cpp/taskflow/taskflow-3.7.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-cpp/taskflow/Manifest b/dev-cpp/taskflow/Manifest
index 356b679b2e87..05b23be00440 100644
--- a/dev-cpp/taskflow/Manifest
+++ b/dev-cpp/taskflow/Manifest
@@ -1,3 +1,4 @@
DIST taskflow-3.3.0.tar.gz 64446007 BLAKE2B 07878a03bd90af64914f1dc80850bcf5d4140f20ecfa998237039b6f37cc668e8c2b5dffafb75f4518209b3ac01f9935f5e30a020871334f131e6fe7654748bf SHA512 08ab20bf38927d49c8332fc103cb7b4b6358efa06466cb8471f2004eb27b79b9eadc9971ec4acd110c8f369686b6f99bf3e21192285c3f28b9cb855bfd9ab0b5
DIST taskflow-3.4.0.tar.gz 64152239 BLAKE2B cec78155bc8db3ac7fb6e61ece8c1bb4697c6655122cdcd987405ce21b1f4f30570debda8a7cccf43d089bac791cb18654e829380e244addae2875ad4fdb47c5 SHA512 e0e3589feec65677c4de6583a70c14f90826f2177636010955c597a3232f7842431c697eae711318f4a64fae52ac3e33e2d0739ef36bb7c57698110b6fa4740d
DIST taskflow-3.6.0.tar.gz 66335249 BLAKE2B bcdc6d721e32b7c40f65ed5bd115d2c0083663e8b51c0e4460baa5f62e576382a45e8da735119b577d8a6ae7a64c72431654471a3b8335997fdf4f9191ad64af SHA512 1bf17b69cdb29b982fc74b9091f5b6c8fc4fd3004b26afe7e73e71569738e492cf8663b71d98cfbc4e240c08ceb8a99bf51cccce95254710722f89929a4bbea8
+DIST taskflow-3.7.0.tar.gz 66383509 BLAKE2B 92a9d56f0101d507b7f924ce9038d6d43a5f39c9270582f910644ad281ea2cee3f8fa39f3ee4e748f90d013d57a3bc2f24842e328ab345bc580d1a9a5de4f308 SHA512 2faecc9eaf9e7f24253a5aedbb4ef6164ba8b5181b7f2c65d8646c21300f28278d7817e928eeab7e85ec2b9644508a8665bab1a7482ec85a7f6de18cecb32d6f
diff --git a/dev-cpp/taskflow/taskflow-3.7.0.ebuild b/dev-cpp/taskflow/taskflow-3.7.0.ebuild
new file mode 100644
index 000000000000..a9a00cd40a3d
--- /dev/null
+++ b/dev-cpp/taskflow/taskflow-3.7.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Modern C++ Parallel Task Programming"
+HOMEPAGE="https://taskflow.github.io"
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/taskflow/${PN}.git"
+ inherit git-r3
+ S="${WORKDIR}/taskflow-${PV}"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ S="${WORKDIR}/taskflow-${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/doctest )"
+
+HTML_DOCS=( docs/. )
+
+PATCHES=(
+)
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ # TODO: enable CUDA via USE flag
+ local mycmakeargs=(
+ -DTF_BUILD_CUDA=OFF
+ -DTF_BUILD_EXAMPLES=$(usex examples)
+ -DTF_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}