summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2025-01-08 22:29:53 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2025-01-08 22:34:40 +0100
commit2e5181b9470288d76aac0d0f6563120b55702a90 (patch)
tree5d7dd9e198272ad0dc70ad360280f5de7854b0fa /dev-cpp
parentsci-astronomy/stellarium: add 24.4 (diff)
downloadgentoo-2e5181b9470288d76aac0d0f6563120b55702a90.tar.gz
gentoo-2e5181b9470288d76aac0d0f6563120b55702a90.tar.bz2
gentoo-2e5181b9470288d76aac0d0f6563120b55702a90.zip
dev-cpp/eigen: drop 3.4.0-r1
Bug: https://bugs.gentoo.org/927892 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/eigen/Manifest1
-rw-r--r--dev-cpp/eigen/eigen-3.4.0-r1.ebuild106
-rw-r--r--dev-cpp/eigen/files/eigen-3.3.7-gentoo-cmake.patch24
3 files changed, 0 insertions, 131 deletions
diff --git a/dev-cpp/eigen/Manifest b/dev-cpp/eigen/Manifest
index 02571f1672eb..1f60bcb2825e 100644
--- a/dev-cpp/eigen/Manifest
+++ b/dev-cpp/eigen/Manifest
@@ -1,3 +1,2 @@
DIST eigen-3.4.0.tar.bz2 2143091 BLAKE2B a32aac13cbab68cfaaa252d8a406e6a36ecfd1239361412b1f9baa08284a94467479c08ffae10cb847e9916472b46b1c1af4efbf81f957c8200a4379acd42c42 SHA512 cc488eb111e0e248744d2bc4475b345b5fb82361dff226a5b73a33bd0388de8c219cff8cffcf8f476b672fc0e223f339e8c6a1cfb6293840a4a6abf232438a89
-DIST eigen-3.4.0.tar.gz 2705005 BLAKE2B ae5f774a6ed36f52cf9fc3206e50796abacbba69fd0f67cd5759b4e04d847aa656861d5e06e6cd0d798a17f2b06abdb70b16f795a626bdd29edcc872c33821f8 SHA512 ba75ecb760e32acf4ceaf27115468e65d4f77c44f8d519b5a13e7940af2c03a304ad433368cb6d55431f307c5c39e2666ab41d34442db3cf441638e51f5c3b6a
DIST eigen-lapack_addons-3.4.1.tgz 6215074 BLAKE2B 564c3398de1f4ea249b58957a482cda0b5eb99e5021e1f18abf3b4d2893fed48912bfa8386681fcae03dd933eea91644f7429d47a53684d64462209a6ae76f30 SHA512 5a827d0befb521cb430f0d63f5000e7955359bc637cdb7292d942712e98c0702570a5b650a72fc609bf5b43633661c0e51de7761ae892df6ff0aab667f436edf
diff --git a/dev-cpp/eigen/eigen-3.4.0-r1.ebuild b/dev-cpp/eigen/eigen-3.4.0-r1.ebuild
deleted file mode 100644
index 708a6acc8779..000000000000
--- a/dev-cpp/eigen/eigen-3.4.0-r1.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-FORTRAN_NEEDED="test"
-inherit cmake cuda fortran-2
-
-DESCRIPTION="C++ template library for linear algebra"
-HOMEPAGE="https://eigen.tuxfamily.org/index.php?title=Main_Page"
-SRC_URI="https://gitlab.com/lib${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="3"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
-IUSE="cpu_flags_arm_neon cpu_flags_ppc_altivec cpu_flags_ppc_vsx cuda debug doc openmp test" #zvector
-
-# Tests failing again because of compiler issues
-RESTRICT="!test? ( test ) test"
-
-BDEPEND="
- doc? (
- app-text/doxygen[dot]
- dev-texlive/texlive-bibtexextra
- dev-texlive/texlive-fontsextra
- dev-texlive/texlive-fontutils
- dev-texlive/texlive-latex
- dev-texlive/texlive-latexextra
- )
- test? ( virtual/pkgconfig )
-"
-DEPEND="
- cuda? ( dev-util/nvidia-cuda-toolkit )
- test? (
- dev-libs/gmp:0
- dev-libs/mpfr:0
- media-libs/freeglut
- media-libs/glew
- sci-libs/adolc[sparse]
- sci-libs/cholmod
- sci-libs/fftw:3.0
- sci-libs/pastix
- sci-libs/scotch
- sci-libs/spqr
- sci-libs/superlu
- sci-libs/umfpack
- virtual/opengl
- )
-"
-# Missing:
-# METIS-5
-# GOOGLEHASH
-
-PATCHES=(
- #"${FILESDIR}"/${PN}-3.3.7-gentoo-cmake.patch
- "${FILESDIR}"/${PN}-3.3.9-max-macro.patch
- "${FILESDIR}"/${P}-doc-nocompress.patch # bug 830064
-)
-
-src_prepare() {
- cmake_src_prepare
-
- cmake_comment_add_subdirectory demos
-
- if ! use test; then
- sed -e "/add_subdirectory(test/s/^/#DONOTCOMPILE /g" \
- -e "/add_subdirectory(blas/s/^/#DONOTCOMPILE /g" \
- -e "/add_subdirectory(lapack/s/^/#DONOTCOMPILE /g" \
- -i CMakeLists.txt || die
- fi
-
- use cuda && cuda_src_prepare
-}
-
-src_configure() {
- use test && mycmakeargs+=(
- # the OpenGL testsuite is extremely brittle, bug #712808
- -DEIGEN_TEST_NO_OPENGL=ON
- # the cholmod tests are broken and always fail
- -DCMAKE_DISABLE_FIND_PACKAGE_Cholmod=ON
- -DEIGEN_TEST_CXX11=ON
- -DEIGEN_TEST_NOQT=ON
- -DEIGEN_TEST_ALTIVEC=$(usex cpu_flags_ppc_altivec)
- -DEIGEN_TEST_CUDA=$(usex cuda)
- -DEIGEN_TEST_OPENMP=$(usex openmp)
- -DEIGEN_TEST_NEON64=$(usex cpu_flags_arm_neon)
- -DEIGEN_TEST_VSX=$(usex cpu_flags_ppc_vsx)
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- if use doc; then
- cmake_src_compile doc
- HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
- fi
- if use test; then
- cmake_src_compile blas
- cmake_src_compile buildtests
-
- # tests generate random data, which
- # obviously fails for some seeds
- export EIGEN_SEED=712808
- fi
-}
diff --git a/dev-cpp/eigen/files/eigen-3.3.7-gentoo-cmake.patch b/dev-cpp/eigen/files/eigen-3.3.7-gentoo-cmake.patch
deleted file mode 100644
index 0389cd3b9333..000000000000
--- a/dev-cpp/eigen/files/eigen-3.3.7-gentoo-cmake.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Let us properly override with CMAKE_BUILD_TYPE=Gentoo
-
---- a/CMakeLists.txt 2018-12-11 18:57:55.000000000 +0100
-+++ b/CMakeLists.txt 2020-07-21 16:43:33.467680534 +0200
-@@ -14,18 +14,7 @@
- set(Eigen_BINARY_DIR ${Eigen3_BINARY_DIR})
-
- # guard against bad build-type strings
--
--if (NOT CMAKE_BUILD_TYPE)
-- set(CMAKE_BUILD_TYPE "Release")
--endif()
--
--string(TOLOWER "${CMAKE_BUILD_TYPE}" cmake_build_type_tolower)
--if( NOT cmake_build_type_tolower STREQUAL "debug"
-- AND NOT cmake_build_type_tolower STREQUAL "release"
-- AND NOT cmake_build_type_tolower STREQUAL "relwithdebinfo")
-- message(FATAL_ERROR "Unknown build type \"${CMAKE_BUILD_TYPE}\". Allowed values are Debug, Release, RelWithDebInfo (case-insensitive).")
--endif()
--
-+# yeah no.
-
- #############################################################################
- # retrieve version infomation #