summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteffen Winter <steffen.winter@proton.me>2024-11-24 21:12:23 +0100
committerSam James <sam@gentoo.org>2024-12-01 11:44:36 +0000
commit7d5830ca72b0fa331c9772968a603869647c674a (patch)
treea2b06b27ba32601fddf746f058ce446229edf542 /dev-cpp
parentdev-vcs/git-lfs: Drop obsolete stable ebuild (diff)
downloadgentoo-7d5830ca72b0fa331c9772968a603869647c674a.tar.gz
gentoo-7d5830ca72b0fa331c9772968a603869647c674a.tar.bz2
gentoo-7d5830ca72b0fa331c9772968a603869647c674a.zip
dev-cpp/fast_float: add 7.0.0
Signed-off-by: Steffen Winter <steffen.winter@proton.me> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/fast_float/Manifest1
-rw-r--r--dev-cpp/fast_float/fast_float-7.0.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-cpp/fast_float/Manifest b/dev-cpp/fast_float/Manifest
index b4b2a441fd7f..b69b2ab65e2d 100644
--- a/dev-cpp/fast_float/Manifest
+++ b/dev-cpp/fast_float/Manifest
@@ -1 +1,2 @@
DIST fast_float-6.1.6.tar.gz 101727 BLAKE2B eb9833f7bff6e6086db1525fcc71231c5cc8f47985aa4c71078d896afb5fea20c41bfdb55de6c1e8c9cfa6c9b842331f340115590683e1d9e6a3ba40f4148870 SHA512 d2dbd2537f433329a76539c061238af080125526b7822fbfdf0f70ac0a6800114848b9be0fdf9c51dbb22211af3bdcf9829ed9cc4a47fd28ecdeecf7c5d4b663
+DIST fast_float-7.0.0.tar.gz 103358 BLAKE2B 7334a74952aba9629e0cd0f3b49679ed8f9c84436d3e9b10438d09416341343efc34acc0f87283a20fff5866d1e5787f456ac8a37f0a918823369419378ddb53 SHA512 d6745c0f7d3b7fd31d710ca1a5b8a58506d0009dbf2e1a29c70483abcec2c2498a15a5efef203f39b43a9357a04c91e360080b7897fffdf68bf4ec561c40c77d
diff --git a/dev-cpp/fast_float/fast_float-7.0.0.ebuild b/dev-cpp/fast_float/fast_float-7.0.0.ebuild
new file mode 100644
index 000000000000..974c160275da
--- /dev/null
+++ b/dev-cpp/fast_float/fast_float-7.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Fast and exact implementation of the C++ from_chars functions for number types"
+HOMEPAGE="https://github.com/fastfloat/fast_float"
+SRC_URI="https://github.com/fastfloat/fast_float/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 Boost-1.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="test"
+
+BDEPEND="test? ( dev-cpp/doctest )"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=( -DFASTFLOAT_TEST=$(usex test) )
+ # Avoid passing these without USE=test to avoid cmake warning
+ # "Manually-specified variables were not used by the project"
+ use test && mycmakeargs+=(
+ -DSYSTEM_DOCTEST=ON
+ # Unconditionally calls FetchContent
+ -DFASTFLOAT_SUPPLEMENTAL_TESTS=OFF
+ )
+
+ sed -i 's/-Werror//' tests/CMakeLists.txt || die
+
+ cmake_src_configure
+}