summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2017-09-05 18:09:31 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-09-21 21:50:01 +0200
commit4fb6b5123a834fbb1d1726aaeebee2ec3ad79fa4 (patch)
tree49065bbf37301d256d7d2203c674c8a20861ce7f /dev-db/mongodb/mongodb-3.2.16.ebuild
parentdev-db/mongodb: version bump to 3.4.7. (diff)
downloadgentoo-4fb6b5123a834fbb1d1726aaeebee2ec3ad79fa4.tar.gz
gentoo-4fb6b5123a834fbb1d1726aaeebee2ec3ad79fa4.tar.bz2
gentoo-4fb6b5123a834fbb1d1726aaeebee2ec3ad79fa4.zip
dev-db/mongodb: fix building with newer libpcre/glibc.
Gentoo-Bug: https://bugs.gentoo.org/580768 Gentoo-Bug: https://bugs.gentoo.org/625148 Gentoo-Bug: https://bugs.gentoo.org/626342 Package-Manager: Portage-2.3.8, Repoman-2.3.2
Diffstat (limited to 'dev-db/mongodb/mongodb-3.2.16.ebuild')
-rw-r--r--dev-db/mongodb/mongodb-3.2.16.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/dev-db/mongodb/mongodb-3.2.16.ebuild b/dev-db/mongodb/mongodb-3.2.16.ebuild
index c7a04e63cca5..f18602bddd95 100644
--- a/dev-db/mongodb/mongodb-3.2.16.ebuild
+++ b/dev-db/mongodb/mongodb-3.2.16.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
SCONS_MIN_VERSION="2.3.0"
CHECKREQS_DISK_BUILD="2400M"
CHECKREQS_DISK_USR="512M"
@@ -44,6 +44,14 @@ DEPEND="${RDEPEND}
)"
PDEPEND="tools? ( >=app-admin/mongo-tools-${PV} )"
+PATCHES=(
+ "${FILESDIR}/${PN}-3.2.0-fix-scons.patch"
+ "${FILESDIR}/${PN}-3.2.4-boost-1.60.patch"
+ "${FILESDIR}/${PN}-3.2.10-boost-1.62.patch"
+ "${FILESDIR}/${PN}-3.2.16-Replace-string-with-explicit-std-string.patch"
+ "${FILESDIR}/${PN}-3.4.6-sysmacros-include.patch"
+)
+
S=${WORKDIR}/${MY_P}
pkg_pretend() {
@@ -99,16 +107,6 @@ pkg_setup() {
fi
}
-src_prepare() {
- epatch \
- "${FILESDIR}/${PN}-3.2.0-fix-scons.patch" \
- "${FILESDIR}/${PN}-3.2.4-boost-1.60.patch"
- if has_version ">=dev-libs/boost-1.62"; then
- epatch "${FILESDIR}/${PN}-3.2.10-boost-1.62.patch"
- fi
- epatch_user
-}
-
src_compile() {
# respect mongoDB upstream's basic recommendations
# see bug #536688 and #526114
@@ -122,6 +120,7 @@ src_compile() {
src_install() {
escons "${scons_opts[@]}" --nostrip install --prefix="${ED}"/usr
+ local x
for x in /var/{lib,log}/${PN}; do
keepdir "${x}"
fowners mongodb:mongodb "${x}"
@@ -157,7 +156,7 @@ pkg_preinst() {
src_test() {
# this one test fails
- rm jstests/core/repl_write_threads_start_param.js
+ rm jstests/core/repl_write_threads_start_param.js || die
./buildscripts/resmoke.py --dbpathPrefix=test --suites core || die "Tests failed"
}