summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-03-07 12:56:14 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-07 12:56:14 +0100
commit67071be387ad62b948ac5f48d883ca3f7b0239c6 (patch)
tree900ef0f1b8828128ecf3acdcd08da67dcecac434 /dev-db/postgresql/postgresql-9999.ebuild
parentdev-db/etcd: migrate to tmpfiles.eclass (diff)
downloadgentoo-67071be387ad62b948ac5f48d883ca3f7b0239c6.tar.gz
gentoo-67071be387ad62b948ac5f48d883ca3f7b0239c6.tar.bz2
gentoo-67071be387ad62b948ac5f48d883ca3f7b0239c6.zip
dev-db/postgresql: migrate to tmpfiles.eclass
Closes: https://bugs.gentoo.org/740592 Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-db/postgresql/postgresql-9999.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-db/postgresql/postgresql-9999.ebuild b/dev-db/postgresql/postgresql-9999.ebuild
index ea330b58b0bb..c9a4ce82776c 100644
--- a/dev-db/postgresql/postgresql-9999.ebuild
+++ b/dev-db/postgresql/postgresql-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
inherit flag-o-matic git-r3 linux-info multilib pam prefix python-single-r1 \
- systemd
+ systemd tmpfiles
KEYWORDS=""
@@ -209,7 +209,7 @@ src_install() {
sed -e "s|@SLOT@|${SLOT}|g" -e "s|@LIBDIR@|$(get_libdir)|g" \
"${FILESDIR}/${PN}.service-9.6-r1" | \
systemd_newunit - ${PN}-${SLOT}.service
- systemd_newtmpfilesd "${FILESDIR}"/${PN}.tmpfiles ${PN}-${SLOT}.conf
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfiles ${PN}-${SLOT}.conf
fi
newbin "${FILESDIR}"/${PN}-check-db-dir ${PN}-${SLOT}-check-db-dir
@@ -293,7 +293,7 @@ pkg_preinst() {
}
pkg_postinst() {
- use systemd && systemd_tmpfiles_create ${PN}-${SLOT}.conf
+ use systemd && tmpfiles_process ${PN}-${SLOT}.conf
postgresql-config update
elog "If you need a global psqlrc-file, you can place it in:"