summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRobert Förster <Dessa@gmake.de>2024-09-10 16:09:11 +0200
committerSam James <sam@gentoo.org>2024-12-11 05:45:55 +0000
commit749ec8c1b84540151fa6bbec73ae5ce4cb5554ac (patch)
treeabf97a0687f3fa1f26e1239708768d1d60f4e7b6 /dev-db
parentapp-text/po4a: apply patch from upstream for xsl lookup (diff)
downloadgentoo-749ec8c1b84540151fa6bbec73ae5ce4cb5554ac.tar.gz
gentoo-749ec8c1b84540151fa6bbec73ae5ce4cb5554ac.tar.bz2
gentoo-749ec8c1b84540151fa6bbec73ae5ce4cb5554ac.zip
dev-db/mongodb: rebase boost 1.79 patch and split 1.85 patch in two to reuse it in 6
Signed-off-by: Robert Förster <Dessa@gmake.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mongodb/files/mongodb-5.0.2-boost-1.79.patch4
-rw-r--r--dev-db/mongodb/files/mongodb-5.0.26-boost-1.85-extra.patch16
-rw-r--r--dev-db/mongodb/files/mongodb-5.0.26-boost-1.85.patch9
-rw-r--r--dev-db/mongodb/mongodb-5.0.26.ebuild1
4 files changed, 19 insertions, 11 deletions
diff --git a/dev-db/mongodb/files/mongodb-5.0.2-boost-1.79.patch b/dev-db/mongodb/files/mongodb-5.0.2-boost-1.79.patch
index 39c76bacf426..de4c11ea2844 100644
--- a/dev-db/mongodb/files/mongodb-5.0.2-boost-1.79.patch
+++ b/dev-db/mongodb/files/mongodb-5.0.2-boost-1.79.patch
@@ -37,8 +37,8 @@ https://bugs.gentoo.org/844235
#include <boost/filesystem.hpp>
+#include <boost/filesystem/fstream.hpp>
#include <boost/filesystem/path.hpp>
-
- #include "mongo/base/simple_string_data_comparator.h"
+ #include <pcrecpp.h>
+
--- a/src/mongo/shell/shell_utils_extended.cpp
+++ b/src/mongo/shell/shell_utils_extended.cpp
@@ -37,6 +37,7 @@
diff --git a/dev-db/mongodb/files/mongodb-5.0.26-boost-1.85-extra.patch b/dev-db/mongodb/files/mongodb-5.0.26-boost-1.85-extra.patch
new file mode 100644
index 000000000000..b3e3aab0c901
--- /dev/null
+++ b/dev-db/mongodb/files/mongodb-5.0.26-boost-1.85-extra.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/932251
+https://github.com/mongodb/mongo/commit/f8e4be7f6da71f978b2aa9991febb4c7ad89c903#diff-010644a9158d28e5745762753c7ce454444c9fb9ab4c684e9f2fdcff50c6f539
+https://bugs.gentoo.org/932251#c3
+
+--- a/src/mongo/db/initialize_server_global_state.cpp
++++ b/src/mongo/db/initialize_server_global_state.cpp
+@@ -328,7 +328,7 @@
+ << "\" should name a file, not a directory.");
+ }
+
+- if (!serverGlobalParams.logAppend && boost::filesystem::is_regular(absoluteLogpath)) {
++ if (!serverGlobalParams.logAppend && boost::filesystem::is_regular_file(absoluteLogpath)) {
+ std::string renameTarget = absoluteLogpath + "." + terseCurrentTimeForFilename();
+ boost::system::error_code ec;
+ boost::filesystem::rename(absoluteLogpath, renameTarget, ec);
+
diff --git a/dev-db/mongodb/files/mongodb-5.0.26-boost-1.85.patch b/dev-db/mongodb/files/mongodb-5.0.26-boost-1.85.patch
index 71da50fe21eb..23bd6f75ffaa 100644
--- a/dev-db/mongodb/files/mongodb-5.0.26-boost-1.85.patch
+++ b/dev-db/mongodb/files/mongodb-5.0.26-boost-1.85.patch
@@ -13,15 +13,6 @@ https://bugs.gentoo.org/932251#c3
#include <fmt/format.h>
#include <iostream>
#include <memory>
-@@ -328,7 +328,7 @@
- << "\" should name a file, not a directory.");
- }
-
-- if (!serverGlobalParams.logAppend && boost::filesystem::is_regular(absoluteLogpath)) {
-+ if (!serverGlobalParams.logAppend && boost::filesystem::is_regular_file(absoluteLogpath)) {
- std::string renameTarget = absoluteLogpath + "." + terseCurrentTimeForFilename();
- boost::system::error_code ec;
- boost::filesystem::rename(absoluteLogpath, renameTarget, ec);
--- a/src/mongo/db/startup_warnings_mongod.cpp
+++ b/src/mongo/db/startup_warnings_mongod.cpp
@@ -34,6 +34,7 @@
diff --git a/dev-db/mongodb/mongodb-5.0.26.ebuild b/dev-db/mongodb/mongodb-5.0.26.ebuild
index efb618e4f155..ae30891c4a94 100644
--- a/dev-db/mongodb/mongodb-5.0.26.ebuild
+++ b/dev-db/mongodb/mongodb-5.0.26.ebuild
@@ -75,6 +75,7 @@ PATCHES=(
"${FILESDIR}/${PN}-5.0.16-arm64-assert.patch"
"${FILESDIR}/${PN}-4.4.29-no-enterprise.patch"
"${FILESDIR}/${PN}-5.0.26-boost-1.85.patch"
+ "${FILESDIR}/${PN}-5.0.26-boost-1.85-extra.patch"
)
python_check_deps() {