summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-21 05:55:31 +0100
committerSam James <sam@gentoo.org>2024-08-21 05:57:18 +0100
commit4d0a6ed89648091f6e250d6aa866cd2e7c1a29fe (patch)
tree400b7b34af3d7a26aed4f61b7fea3bbfdb9d27cf /dev-debug
parentdev-debug/systemtap: add comment wrt bash (diff)
downloadgentoo-4d0a6ed89648091f6e250d6aa866cd2e7c1a29fe.tar.gz
gentoo-4d0a6ed89648091f6e250d6aa866cd2e7c1a29fe.tar.bz2
gentoo-4d0a6ed89648091f6e250d6aa866cd2e7c1a29fe.zip
dev-debug/systemtap: make tests more robust
They failed for me with my usual CFLAGS otherwise (the sanity check / smoketest failed, even). Bug: https://bugs.gentoo.org/868408 Bug: https://bugs.gentoo.org/935333 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/systemtap/systemtap-5.1.ebuild16
-rw-r--r--dev-debug/systemtap/systemtap-9999.ebuild16
2 files changed, 30 insertions, 2 deletions
diff --git a/dev-debug/systemtap/systemtap-5.1.ebuild b/dev-debug/systemtap/systemtap-5.1.ebuild
index 0bdad429da92..df5d1a5ea9c7 100644
--- a/dev-debug/systemtap/systemtap-5.1.ebuild
+++ b/dev-debug/systemtap/systemtap-5.1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} pypy3 )
-inherit autotools linux-info python-single-r1
+inherit autotools flag-o-matic linux-info python-single-r1 toolchain-funcs
DESCRIPTION="Linux trace/probe tool"
HOMEPAGE="https://sourceware.org/systemtap/"
@@ -132,6 +132,20 @@ src_configure() {
CONFIG_SHELL="${BROOT}"/bin/bash PYTHON3="${PYTHON}" econf "${myeconfargs[@]}"
}
+src_test() {
+ # TODO: Install tests like dev-debug/dtrace[install-tests] and
+ # e.g. Fedora does.
+ (
+ strip-flags
+ filter-flags '-fcf-protection=*'
+ filter-flags '-fdiagnostics-color=*' '-fdiagnostics-urls=*'
+ filter-flags '-g*'
+ filter-lto
+ tc-ld-force-bfd
+ emake -Onone -k check CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
+ )
+}
+
src_install() {
default
python_optimize
diff --git a/dev-debug/systemtap/systemtap-9999.ebuild b/dev-debug/systemtap/systemtap-9999.ebuild
index 0bdad429da92..df5d1a5ea9c7 100644
--- a/dev-debug/systemtap/systemtap-9999.ebuild
+++ b/dev-debug/systemtap/systemtap-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} pypy3 )
-inherit autotools linux-info python-single-r1
+inherit autotools flag-o-matic linux-info python-single-r1 toolchain-funcs
DESCRIPTION="Linux trace/probe tool"
HOMEPAGE="https://sourceware.org/systemtap/"
@@ -132,6 +132,20 @@ src_configure() {
CONFIG_SHELL="${BROOT}"/bin/bash PYTHON3="${PYTHON}" econf "${myeconfargs[@]}"
}
+src_test() {
+ # TODO: Install tests like dev-debug/dtrace[install-tests] and
+ # e.g. Fedora does.
+ (
+ strip-flags
+ filter-flags '-fcf-protection=*'
+ filter-flags '-fdiagnostics-color=*' '-fdiagnostics-urls=*'
+ filter-flags '-g*'
+ filter-lto
+ tc-ld-force-bfd
+ emake -Onone -k check CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
+ )
+}
+
src_install() {
default
python_optimize