summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2025-02-03 22:07:29 +0100
committerSam James <sam@gentoo.org>2025-02-06 01:11:15 +0000
commitd4c7b9e5813055c38d00fd9355dc6e237bccce8e (patch)
treed49d842897bea7db73c3e22ffd4c8fcb5f9baf1e /dev-debug
parentdev-debug/pwndbg: add 20250120 (diff)
downloadgentoo-d4c7b9e5813055c38d00fd9355dc6e237bccce8e.tar.gz
gentoo-d4c7b9e5813055c38d00fd9355dc6e237bccce8e.tar.bz2
gentoo-d4c7b9e5813055c38d00fd9355dc6e237bccce8e.zip
dev-debug/pwndbg: drop 20240214
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/40431 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/pwndbg/Manifest1
-rw-r--r--dev-debug/pwndbg/pwndbg-20240214.ebuild77
2 files changed, 0 insertions, 78 deletions
diff --git a/dev-debug/pwndbg/Manifest b/dev-debug/pwndbg/Manifest
index 0bda2118a6db..3a8f4a7693d5 100644
--- a/dev-debug/pwndbg/Manifest
+++ b/dev-debug/pwndbg/Manifest
@@ -1,3 +1,2 @@
-DIST pwndbg-20240214.tar.gz 8536795 BLAKE2B 75524fb9f701769f2a117b4aa1158f648cd854fd38475c20bee4b7ae27ae8f331c40367738a467dd5c7f8994ac80efd3290a64e59ffb9e5a240546be8fb1c6e8 SHA512 3d55e762cecd2b42b9debb36f3ee0a8983be744192d4c1a0424517b0fd8ae8fb329197228a88ddd726e640f1bcd0e0bcdc7e95a64e041630e20cfcbf6acff1aa
DIST pwndbg-20240829.tar.gz 8649207 BLAKE2B 5333c318ba3ccbaaac459f9c7b917d3defa1ad712f45555b31eb76774089e55e80720744dc92813ad8234302445e3bed3237c2275c795a49856028dec416dcc2 SHA512 503924742d4a6d767ec369bb1e37c931afb5ab09f2b4cfa048765ce7a61fb6adcda2576cdda64dd4cf74de27d83b13b4dc09d6e7480e01ae8f646c5394992d43
DIST pwndbg-20250120.tar.gz 8959258 BLAKE2B 58c2c6139d8d96c939c602f694519167d4722f7ed05a92a5c38e55e0a894ffd930813d583e07bc70d0114abdcf8e34e7e859ceeb1113fc0cd00dd4af513f213b SHA512 b619b8b3727a4a23a3146f2bb0f3475ad788e82712cb669d233d88ce546546f114882162df6e5d0b357e9fa143a6829f7387132ee2a7f922dc4e669a215d8d51
diff --git a/dev-debug/pwndbg/pwndbg-20240214.ebuild b/dev-debug/pwndbg/pwndbg-20240214.ebuild
deleted file mode 100644
index 3b74b964df2b..000000000000
--- a/dev-debug/pwndbg/pwndbg-20240214.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-DISTUTILS_SINGLE_IMPL=1
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 wrapper
-
-DESCRIPTION="A GDB plug-in that makes debugging with GDB suck less"
-HOMEPAGE="https://github.com/pwndbg/pwndbg"
-
-if [[ ${PV} == "99999999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/pwndbg/pwndbg"
-else
- MY_PV="${PV:0:4}.${PV:4:2}.${PV:6:2}"
- SRC_URI="https://github.com/pwndbg/pwndbg/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm64 x86"
- S="${WORKDIR}/${PN}-${MY_PV}"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="
- dev-debug/gdb[python,${PYTHON_SINGLE_USEDEP}]
- ~dev-python/gdb-pt-dump-0.0.0_p20231111[${PYTHON_SINGLE_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-libs/capstone-5.0_rc4[python,${PYTHON_USEDEP}]
- >=dev-python/psutil-5.9.5[${PYTHON_USEDEP}]
- >=dev-python/pycparser-2.21[${PYTHON_USEDEP}]
- >=dev-python/pyelftools-0.29[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.15.1[${PYTHON_USEDEP}]
- >=dev-python/tabulate-0.9.0[${PYTHON_USEDEP}]
- >=dev-python/typing-extensions-4.6.1[${PYTHON_USEDEP}]
- >=dev-util/pwntools-4.11.0[${PYTHON_USEDEP}]
- >=dev-util/ROPgadget-7.2[${PYTHON_USEDEP}]
- >=dev-util/unicorn-2.0.1[python,${PYTHON_USEDEP}]
- ')
-"
-
-# Tests are architectur-specific (precompiled binaries)
-RESTRICT="test"
-
-src_install() {
- distutils-r1_src_install
-
- insinto /usr/share/${PN}
- doins gdbinit.py
-
- # Signal pwndbg not to create it's own python venv (Bug #918705).
- # See: https://github.com/pwndbg/pwndbg/commit/139b7542cd9567eaff32bd713df971b6ac5b81de
- touch "${ED}/usr/share/${PN}/.skip-venv" || die
-
- python_optimize "${ED}"/usr/share/${PN}
-
- make_wrapper "pwndbg" \
- "gdb -x \"${EPREFIX}/usr/share/${PN}/gdbinit.py\"" || die
-
- dodoc {README,DEVELOPING,FEATURES}.md
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- einfo "\nUsage:"
- einfo " ~$ pwndbg <program>"
- ewarn "\nWARNING!!!"
- ewarn "Some pwndbg commands only works with libc debug symbols.\n"
- ewarn "See also:"
- ewarn " * https://github.com/pentoo/pentoo-overlay/issues/521#issuecomment-548975884"
- ewarn " * https://sourceware.org/gdb/onlinedocs/gdb/Separate-Debug-Files.html"
- ewarn " * https://wiki.gentoo.org/wiki/Debugging"
- fi
-}