summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGergely Nagy <ngg@ngg.hu>2022-04-20 13:15:00 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-05-06 21:47:07 +0200
commit30bfe6d745c2fc37fa8df7a5e0f8048bf5e6abf3 (patch)
treefb602125e28833189b3cad4110d62e5a06987d3f /dev-dotnet
parentdev-dotnet/dotnet-sdk-bin: bump to 5.0.407 (diff)
downloadgentoo-30bfe6d745c2fc37fa8df7a5e0f8048bf5e6abf3.tar.gz
gentoo-30bfe6d745c2fc37fa8df7a5e0f8048bf5e6abf3.tar.bz2
gentoo-30bfe6d745c2fc37fa8df7a5e0f8048bf5e6abf3.zip
dev-dotnet/dotnet-sdk-bin: bump to 6.0.202
Signed-off-by: Gergely Nagy <ngg@ngg.hu> Closes: https://github.com/gentoo/gentoo/pull/25127 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/dotnet-sdk-bin/Manifest3
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.202.ebuild58
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-dotnet/dotnet-sdk-bin/Manifest b/dev-dotnet/dotnet-sdk-bin/Manifest
index 90e138445abb..25f88d2b99c7 100644
--- a/dev-dotnet/dotnet-sdk-bin/Manifest
+++ b/dev-dotnet/dotnet-sdk-bin/Manifest
@@ -13,3 +13,6 @@ DIST dotnet-sdk-5.0.407-linux-x64.tar.gz 142941732 BLAKE2B 6c049812539aec3ee48c6
DIST dotnet-sdk-6.0.201-linux-arm.tar.gz 172378853 BLAKE2B 46424de89db998dd64696e8c9bc9d421280a1f87e4af100702cdab8a5995f26c6bbe26b4e5e10fdd04b357ad2ac70cdf8e00eaa60ac89c20b75aa4b621492a64 SHA512 5a683430325a90dd1d8e0071a1868939fb01268f9eb389ca1dc40956fde6b9f45bec086553ad3333139e530dfe5afae48195bcdfec388b0b568989924a1f1dd7
DIST dotnet-sdk-6.0.201-linux-arm64.tar.gz 170314335 BLAKE2B 609c2487288982e191f7b2bb795219d44d789311873278a6d75fb72936211530ee21330942b8bf3ab239f752d62f36073da518cbf59f9c4a0dc48fc3f3911a17 SHA512 2ea443c27ab7ca9d566e4df0e842063642394fd22fe2a8620371171c8207ae6a4a72c8c54fc6af5b6b053be25cf9c09a74504f08b963e5bd84544619aed9afc2
DIST dotnet-sdk-6.0.201-linux-x64.tar.gz 176562201 BLAKE2B 842b0483689a2efc66825ae8bc0b074532c26072869d25ceac6e9fd0fcd2814361a840920483c4199e8a30040048e953b31a3c215047d8f0ba77d45760d605f4 SHA512 a4d96b6ca2abb7d71cc2c64282f9bd07cedc52c03d8d6668346ae0cd33a9a670d7185ab0037c8f0ecd6c212141038ed9ea9b19a188d1df2aae10b2683ce818ce
+DIST dotnet-sdk-6.0.202-linux-arm.tar.gz 172857108 BLAKE2B b5bcd76479e4c1204c1de1bded5b97a5540a27d8d456a53538aa96ead10bc2a014f7de2e8ed76fce45bf221c3a6455d0cf79335dec64d5c4ea1867585972e587 SHA512 8c2d56256f4bebe58caee7810b7689408ff023b1f2e68f99fa375f0115db41ef0c3eb160b9ab84dc2764443a045801a4b03f6bc9090e0c1583fca2587ea0d9d6
+DIST dotnet-sdk-6.0.202-linux-arm64.tar.gz 170726144 BLAKE2B 08dd20c5fabfddeda1748b12e0917398bbe1e04ea28cfeb207a732dd6eb98ce46d678c9fe18078f40b7e1f30820ed6774eb10b38469424dc00fb19f44d1fceb3 SHA512 2d0021bb4cd221ffba6888dbd6300e459f45f4f9d3cf7323f3b97ee0f093ef678f5a36d1c982296f4e15bbcbd7275ced72c3e9b2fc754039ba663d0612ffd866
+DIST dotnet-sdk-6.0.202-linux-x64.tar.gz 176864364 BLAKE2B b4460b1a417976e30c8ba2966d0fcc7bb57b705b98585c725559a122326a9bad8a3c647102d70cc1304dafefa48c80af2dc96cfa4c333b06ccd9542d202c8ae0 SHA512 81e9c368d445d9e92e3af471d52dc2aa05e3ecb75ce95c13a2ed1d117852dae43d23d913bbe92eab730aef7f38a14488a1ac65c3b79444026a629647322c5798
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.202.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.202.ebuild
new file mode 100644
index 000000000000..237308fc0fc2
--- /dev/null
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.202.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PV="${PV}"
+
+DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
+HOMEPAGE="https://dotnet.microsoft.com/"
+LICENSE="MIT"
+
+SRC_URI="
+amd64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-x64.tar.gz )
+arm? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm.tar.gz )
+arm64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm64.tar.gz )
+"
+
+SLOT="6.0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+dotnet-symlink"
+REQUIRED_USE="elibc_glibc"
+QA_PREBUILT="*"
+RESTRICT+=" splitdebug"
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-util/lttng-ust:0
+ sys-libs/zlib:0/1
+ dotnet-symlink? (
+ !dev-dotnet/dotnet-sdk[dotnet-symlink(+)]
+ !dev-dotnet/dotnet-sdk-bin:3.1[dotnet-symlink(+)]
+ !dev-dotnet/dotnet-sdk-bin:5.0[dotnet-symlink(+)]
+ )
+"
+
+S=${WORKDIR}
+
+src_install() {
+ local dest="opt/${PN}-${SLOT}"
+ dodir "${dest%/*}"
+
+ # 6.0.100 is SDK feature band which will not change between minor increases, so 6.0.101, 6.102
+ # will still have same 6.0.100 SDK feature band in the name. Thus I have to hard code this
+ # https://github.com/dotnet/sdk/pull/18823#issuecomment-915603684
+ local workloads="metadata/workloads/${SLOT}.100"
+
+ { mkdir -p "${S}/${workloads}" && touch "${S}/${workloads}/userlocal"; } || die
+ { mv "${S}" "${ED}/${dest}" && mkdir "${S}" && fperms 0755 "/${dest}"; } || die
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SLOT}"
+
+ if use dotnet-symlink; then
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet"
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-${SLOT}"
+
+ # set an env-variable for 3rd party tools
+ echo "DOTNET_ROOT=/${dest}" > "${T}/90${PN}-${SLOT}" || die
+ doenvd "${T}/90${PN}-${SLOT}"
+ fi
+}