summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-04-20 22:36:33 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-04-20 22:47:25 +0300
commit64a76907fb19980476a40fd2ae8230af2fe9126b (patch)
tree94c72ae41b0ef4faa75f36e19a0432a985fb46e2 /dev-embedded/libftdi/libftdi-9999.ebuild
parentsys-block/bmap-tools: enable py3.12 (diff)
downloadgentoo-64a76907fb19980476a40fd2ae8230af2fe9126b.tar.gz
gentoo-64a76907fb19980476a40fd2ae8230af2fe9126b.tar.bz2
gentoo-64a76907fb19980476a40fd2ae8230af2fe9126b.zip
dev-embedded/libftdi: enable py3.12
Require >=dev-lang/swig-4.2.0 because that's where they added support for Python 3.12 in swig. In this case this is not strictly required, because swig-4.1.1 generates the same files, so the requirement can be relaxed if needed. Closes: https://bugs.gentoo.org/929394 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'dev-embedded/libftdi/libftdi-9999.ebuild')
-rw-r--r--dev-embedded/libftdi/libftdi-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-embedded/libftdi/libftdi-9999.ebuild b/dev-embedded/libftdi/libftdi-9999.ebuild
index bb804f1f7033..0430681351f7 100644
--- a/dev-embedded/libftdi/libftdi-9999.ebuild
+++ b/dev-embedded/libftdi/libftdi-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake python-single-r1
MY_P="${PN}1-${PV}"
@@ -42,7 +42,7 @@ DEPEND="${RDEPEND}
"
BDEPEND="
doc? ( app-text/doxygen )
- python? ( dev-lang/swig )
+ python? ( >=dev-lang/swig-4.2.0 )
"
pkg_setup() {