summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:05:16 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:02 +0100
commit96c938fe43784ad5635a4adf74e3b7d68313559e (patch)
tree2f08f422bb69de347b27889a1ec1d513fea35f5e /dev-haskell/hslua-cli
parentdev-haskell/hslua-repl: new package, add 0.1.1 (diff)
downloadgentoo-96c938fe43784ad5635a4adf74e3b7d68313559e.tar.gz
gentoo-96c938fe43784ad5635a4adf74e3b7d68313559e.tar.bz2
gentoo-96c938fe43784ad5635a4adf74e3b7d68313559e.zip
dev-haskell/hslua-cli: new package, add 1.4.1
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/hslua-cli')
-rw-r--r--dev-haskell/hslua-cli/Manifest1
-rw-r--r--dev-haskell/hslua-cli/hslua-cli-1.4.1.ebuild33
-rw-r--r--dev-haskell/hslua-cli/metadata.xml15
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-haskell/hslua-cli/Manifest b/dev-haskell/hslua-cli/Manifest
new file mode 100644
index 000000000000..f3ccb8b9f597
--- /dev/null
+++ b/dev-haskell/hslua-cli/Manifest
@@ -0,0 +1 @@
+DIST hslua-cli-1.4.1.tar.gz 5856 BLAKE2B 80f949f9f4146bda9d391d9fe959b817c4cb79c5c75dc9bdee00548d36f14789b78fb7b7022bc9120e249de693cedf72e2acff7a85f3a2fe35d46c2a05b79f36 SHA512 799715a478bd3ee2f5b5c4aa1d5daa2126bacf7d4315855800ce5c4c189bcb340836af614fe22dabbb88f53d0fb509d7f71636ff079c8fce007d6d12032e1639
diff --git a/dev-haskell/hslua-cli/hslua-cli-1.4.1.ebuild b/dev-haskell/hslua-cli/hslua-cli-1.4.1.ebuild
new file mode 100644
index 000000000000..605153581f9c
--- /dev/null
+++ b/dev-haskell/hslua-cli/hslua-cli-1.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Command-line interface for Lua"
+HOMEPAGE="https://hslua.org/"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="executable"
+
+RDEPEND=">=dev-haskell/hslua-core-2.3:=[profile?] <dev-haskell/hslua-core-2.4:=[profile?]
+ >=dev-haskell/hslua-marshalling-2.2:=[profile?] <dev-haskell/hslua-marshalling-2.4:=[profile?]
+ >=dev-haskell/hslua-repl-0.1:=[profile?] <dev-haskell/hslua-repl-0.2:=[profile?]
+ >=dev-haskell/lua-2.3:=[profile?] <dev-haskell/lua-2.4:=[profile?]
+ >=dev-haskell/text-1.2:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable)
+}
diff --git a/dev-haskell/hslua-cli/metadata.xml b/dev-haskell/hslua-cli/metadata.xml
new file mode 100644
index 000000000000..06ebc2e67d14
--- /dev/null
+++ b/dev-haskell/hslua-cli/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="executable">Compile `hslua` standalone executable.</flag>
+ </use>
+ <upstream>
+ <remote-id type="hackage">hslua-cli</remote-id>
+ <remote-id type="github">hslua/hslua</remote-id>
+ </upstream>
+</pkgmetadata>