summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-22 22:23:52 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-22 22:31:17 +0100
commit6b57a26f514e37ea9c8879126d6e2e4c64553103 (patch)
tree445c70aec5a610c428f60c773c9c8c4c0a6c8d49 /dev-haskell/mod/mod-0.1.1.0.ebuild
parentdev-haskell/quickcheck-classes: new package, a depend of arithmoi-0.11 (diff)
downloadgentoo-6b57a26f514e37ea9c8879126d6e2e4c64553103.tar.gz
gentoo-6b57a26f514e37ea9c8879126d6e2e4c64553103.tar.bz2
gentoo-6b57a26f514e37ea9c8879126d6e2e4c64553103.zip
dev-haskell/mod: new package, a depend of arithmoi-0.11
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/mod/mod-0.1.1.0.ebuild')
-rw-r--r--dev-haskell/mod/mod-0.1.1.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/mod/mod-0.1.1.0.ebuild b/dev-haskell/mod/mod-0.1.1.0.ebuild
new file mode 100644
index 000000000000..cf308500308e
--- /dev/null
+++ b/dev-haskell/mod/mod-0.1.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast type-safe modular arithmetic"
+HOMEPAGE="https://github.com/Bodigrim/mod"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+semirings"
+
+RDEPEND=">=dev-lang/ghc-8.2.1:=
+ semirings? ( >=dev-haskell/semirings-0.5:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.0.0.2
+ test? ( dev-haskell/quickcheck-classes-base
+ >=dev-haskell/tasty-0.10
+ >=dev-haskell/tasty-quickcheck-0.9 <dev-haskell/tasty-quickcheck-0.11
+ semirings? ( >=dev-haskell/quickcheck-classes-0.6.3 ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag semirings semirings)
+}